Linking more than two scenes

I may have backed myself into a corner here.

I decided to build to build an image from several scenes using the set link option in the render interface.

  1. Spoon
  2. Glass
  3. Glass holder (it’s hot)
  4. Cloth on table top
  5. Final scene with lighting and camera.

While each scene can have one linked scene to act as a reference for position and size I’ve now discovered that a scene can have only one linked scene.

I thought I could roll the linking through the scenes - scene 2 has scene 1 linked, scene 3 has scene 2 linked (which has scene 1 linked) etc. But this doesn’t worked with the previously linked scene being dropped.

Scene 5 should contain all the elements from scenes 1 through 4.

Any way around this?

Ctrl+L key should do it.
This will bring up a menue to link data from different scenes.
Choose “To Scene” and then select the scene you wish to link to.
You will be able to put all the elements in one scene.

Have you considered using layers? Might be better if there aren’t too many elements.

OK - I get that CTL-L menu and choose a scene - but then absolutely nothing happens that I can see.

all those scenes must first be “appended” to the current blend-file first…

Shift+F1 —> go into what ever blendfile you want, and browse for the Scene directory and pick the scenes name…voila…and then this linking will work…

it is strange, I thought it would be great to link in what ever file you want from any file…but I guess they didnt think of that from very beginning…

good luck

oops sorry. Missed that part. It won’t work 'till you do what ztonzy said.

Would this be hard to implement?

My 5 scenes are in the same blender file that includes my final composite scene so I shouldn’t need to append anything.

However, I opened a new blender file, went to file|append and chose a scene from my existing blender file. That loads the scene into the new blender file from where it’s available in the scene menu at the top.

I then try CTL-L (actually, your current scene cannot be empty when you do this - you have to create a dummy object) and link to the scene. Once more, nothing happens. Having appended all my scenes from the old blender file, where I end up is more or less where I started but with a second blender file.

I’ve also tried appending objects rather than scenes. This looked like it might work except it only works for some of my objects - others just come up blank.

Can you post the .blend?

You probably know this but when you append objects from different files be sure to look for them in their “native layer” the layer they were in in the old file.

http://www.sirfragalot.com/blender-files/espresso-3.blend

Thanks. Nice models. Ok I made a new .blend and appended all the objects into one scene. They are in their separate layers and the auto tracking constraints are there as well.

http://lennon.csufresno.edu/~rwv01/espresso_4.blend

I’m not sure why it won’t work with Ctrl+L but it’s all together now.

Thanks. Working fine with a few adjustments the latest results can be found at:
http://www.elysiun.com/forum/viewtopic.php?p=294479#294479

I’m still having no luck getting the spoon to cast a shadow…

For steam on the coffeee should I be looking into the particle system?

And I’d still be interested to know if it’s possible to link scenes together in the way I’ve described or whether I should just stick to using layers for simultaneous compositing and use scenes (in the sequencer) for successive compositing.

Looking at your file again the problem is with the lighting. The spoon is casting a shadow but it’s getting washed out by the lights. In this file there’s 2 lights right over the spoon and cup.

I think it would be the best way.

As far as linking scenes goes, the only way I know is to have them all in one file and link them with Ctrl+L.

For the other part of your question I would think layers would suffice for most things, but you’ll have to ask someone with more experience in the sequence editor.

Looking at your file again the problem is with the lighting. The spoon is casting a shadow but it’s getting washed out by the lights. In this file there’s 2 lights right over the spoon and cup. [/quote]

Nope - that’s not it. If I take out all lights except the spotlight which is up and behind the vase and glass I still get no shadow cast by the spoon.

It’s kind of hard to get it to show but it’s there. It does seem way too faint though. If you want when I have time I’ll experiment with the lighting and see what I can do.

In the .blend you posted you have your spoon set up correctly to cast shadows, ie: tracable is on in shaders, shadow buffer is on for the spot, and shadow calculation is on in the render buttons.

For now here’s a test version with one spot light with it’s shadow bias at a low setting.

http://lennon.csufresno.edu/~rwv01/espresso_5.blend