Linux/Blender: CUDA cuInit: Unknown error ... had worked before


My setup is as follows:
Blender 2.83 / Blender 2.82a
Linux kernel 5.5.15
nvidia-drivers-440.64 / nvidia-drivers-440.82
GeForce RTX 2060 SUPER

This setup (nvidia-driver 440.64) has worked before. Then I moved the whole system to an internal SSD, and reinstalled the kernel and the driver (with the same configuration).
Now Blender does not find the CUDA device.
I removed the file
$HOME/.config/blender/2.83/config/platform_support.txt and restart blender, so it will be recreated.
The contents of the newly created file is:
{NVIDIA Corporation/GeForce RTX 2060 SUPER/PCIe/SSE2/4.5.0 NVIDIA 440.64}=SUPPORTED

So from this point of view - no problem.
The user preferences states, that there was no compatible CUDA device found.
The console output shows:
CUDA cuInit: Unknown error

This happens with the stable blender version 2.82a as with the daily of yesterday and today.

I straced the blender start and didn’t find anything taht would ring a bell in my head.

I started blender as root to pinpoint any permission problems … root gets the same problems.

A helping hand would be very appreciated here since I have currently no idea, what the reason could be for this…

Thanks a lot in advance for any support! Stay healthy!

What is your Linux distribution?
Share the output of the following commands here:

cat /proc/driver/nvidia/version

nvcc --version