Linux - Blender Output to Wrong Audio Device (PulseAudio), Unable to Correct

Greetings, I have Blender 2.76 installed on Mint Linux.
I have NVIDIA HDMI Audio to my TV and a Auzentech X-Fi Forte 7.1 PCI-E sound card.
I am using PulseAudio (pavucontrol). For whatever reason, even though I can see that sound is being output by Blender (visible on the volume indicator in pavucontrol), it is set to the wrong audio device. With any other application (Firefox, Chrome, VLC, Star Wars: The Old Republic, etc), I was able to select the controller for my HDMI Audio and hear the sound.
I am unable to do this for Blender. The HDMI controller shows in the menu but when I click it, nothing happens.
I posted about it here:




The screen shot shows sound from Firefox going to my HDMI which works fine.
However, Blender seems to default to whatever else is enabled besides HDMI and clicking the HDMI controller doesn’t work.

Removed and reinstalled PulseAudio
Made sure my audio strip was not muted in Blender
In User Preferences > System > Audio, it is set to OpenAL (No option for Pulse).

While the sound works fine in Windows 7, I would much prefer to get it working in Linux.

If anyone can help me, I would greatly appreciate it (and give you mention in a thank-you video).

Cheers,
Jeremy

I noticed the same behaviour on Ubuntu 16.04 with the Mate desktop.

Changing Blender’s user preferences from OpenAL to SDL allows changing the pulse output here.

Blender recommends OpenAL for game engine output and SDL for sequencer output. It’s probably not that simple, but SDL might do what you need.

Thank you, however, I do not have SDL as an option in Sound:


Here is what I have installed in Synaptic Package Manager:


I resolved the issue by updating from 2.76 to 2.78 RC1 using the following 3 commands:
sudo add-apt-repository ppa:thomas-schiex/blender
sudo apt-get update
sudo apt-get install blender

This added SDL as an option under User Preferences > System > Audio. I was then able to select the correct audio device in PulseAudio Volume Control (pavucontrol).
Cheers!