linux blender whats the right file

hi there,
i am doing my first steps in the linux world with suse. with the yast system i installed blender 2.37.
but of course i want 2.42.
but what is the right version to download? linux i386,static…dynamic …linuxppc …etc
how often new rpm files occur on the net or isn´t it worth to wait?

thanks.

static : means with libraries coming with the program
dynamic : link to dynamic libraries present on the system

…so dynamic is okay ( I think static is without opengl )

try this one. Just uncompress it, and run it.

http://download.blender.org/release/Blender2.42/blender-2.42a-linux-glibc232-py24-i386.tar.bz2