Linux: Ctrl+z dosen't undo, and my dvix codec doesn't appear

Hey all

I’m running blender v2.34 on Suse 9.2 pro and I’ve noticed that the “Ctrl+Z” doesn’t undo, instead it changes to Shaded mode…how can I get my undo back or what is the keyboard shortcut under linux (does it have a different one maybe)?

Also, I have the divx codecs installed and they work fine for viewing my avi’s but I can’t use them as a render option in blender. For some reason they don’t appear as an option for rendering animation, All I have is “avi jpeg” and “avi raw”…any idea why and how to fix please?

ctrl-z works here – perhaps your ctrl key is stuck???

In linux the formats you mentioned are all that are avaiable. Just save as avi raw (100% quality) or a sequence of png or tga images and then use another program to encode (ie. mplayer or avidemux)

Here is a shell script I use to convert pngs to a movie using mplayer:


TMPFILE=/home/rjplus/enc-$$.avi

if [ $# -ne 2 -a $# -ne 3 ]
then
        echo "usage: picbasename [audiofilename] outputfilename"
        exit 1
fi


if [ $# -eq 2 ]
then
       mencoder -fps 25 -o $2 -ovc lavc -lavcopts vcodec=mpeg4 mf://"$1"\*.png
else
        trap "rm -f $TMPFILE" 1 2
        mencoder -fps 24 -o $TMPFILE -ovc lavc -lavcopts vcodec=mpeg4 mf://"$1"\*.png
        mencoder -o $3 -ovc copy -audiofile $2 -oac copy $TMPFILE
        rm -f $TMPFILE
fi

GreyBeard

I’m running blender v2.34 on Suse 9.2 pro and I’ve noticed that the “Ctrl+Z” doesn’t undo, instead it changes to Shaded mode…how can I get my undo back or what is the keyboard shortcut under linux (does it have a different one maybe)?

Undo Is still a fairly new feature, and the version of Blender you are using does not support it…

Also, I have the divx codecs installed and they work fine for viewing my avi’s but I can’t use them as a render option in blender. For some reason they don’t appear as an option for rendering animation, All I have is “avi jpeg” and “avi raw”…any idea why and how to fix please?

DivX is a proprietary format (I think, but don’t quote me) and the support on Linux isn’t really official, so a true DivX file can’t be made. However, Blender 2.4 will support FFMPEG codecs which can simulate and export to a DivX file, without breaking any laws.

(Let me reiterate that I am NOT a codec person, so that information and the small details may be wrong, but for the most part it is right: Linux isn’t supposed to support DivX, though some have hacked it, or use the older version)

I suggest getting a newer copy of Blender from the site…

Hold on Tight,
Ongnissim

P.S. Ctrl-Z isn’t for shaded mode, it’s just Z…

Thanks for the script greybeard…very handy!

I’m still a linux newb and am doing my best to get to grips with it atm.

I was running a WinXP\Suse duel boot system for about 6months but spent most of my time in windows, mainly cause I couldn’t get my Intel 536ep modem installed.

Two weeks ago I did something stupid and lost my windows. Then things got a bit complex and I didn’t want to mess up my linux too…so I decided to bite the bullet and see if I can’t do without windows altogether.

The only thing that I still needed to sort was the modem thing…took me a week but I got it…yayyyyy!

So anyways…now I can d/load the latest blender for linux which should sort some things for me.

Thanks for the info too Ongnissim.

correct, the avi codec feature only exists in windows [because it depends on the windows codec system, something linux doesn’t really have]

ffmpeg support should allow you to render to similar, but I’d still argue you’re better off encoding after rendering.