Linux graphics drivers problem: Solved. Now I need Yafray installation help.

I finally got my computer fixed, and I’m going to use ubuntu Linux from now on, and… It has no OpenGL support, or drivers for my graphics card. I just installed Ubuntu today, and when I try to install the drivers for my nVidia card, I get this error:

ERROR: Unable to find the system utility ld; please make sure you have the package ‘binutils’ installed. If you do have binutils installed, then please check that ld is in your PATH.

Does anyone know what this means and how to fix it?

Don’t say to use Sudo, I did.

Not to be a smart-ass but… the clearest reading would be that you need the binutils package, and should probably locate and install it. It’s sort of important.

Try an

apt-get --install binutils

Or try checking Synaptic (or whichever package utility you’re using).

Or check here -

It’s kind of odd that Ubuntu installs default without the bin utils, but c’est la vie.

1: I don’t have internet.
2: If binutils is more than 128 megs, I can’t put it on my thumbdrive.
3: If it’s so important, why doesn’t it come with Ubuntu?

Edit: Sorry, didn’t go to the link you had before. As soon as I get home I’ll install it. Thanks!

Are there any other software packages I need to know of?

I’m not an ubuntu user, but “ld” is used to link programs. As far as I know Ubuntu doesn’t come with any development utils/programs, so you have to install it yourself.

I can however guarantee you, that downloading binutils will not help you, since you will need much more packages, such as kernel-headers etc.

Looking at manual page of apt-get you should try something like this
apt-get --simulate install binutils build-essential kernel-headers-2.6.15-1-k7
apt-get --print-uris install binutils build-essential kernel-headers-2.6.15-1-k7

This will help you to find all packages you need to download. I’m sure someone who actually uses ubuntu will be able to help a little more.

As for, why do you need so much things to download to get your driver running, it’s because NVidia drivers are not open source, so they are distributed in a binary way, which is a little problematic, since Linuxes way of communication with drivers (ABI) changes all the time. So NVidia is distributing a little utility which will be compiled against your current kernel and which will form a bridge between the kernel and the nvidia driver. That’s the reason you need development utilities to be installed.

your best bet is to write down any dependencies missing, then go to , find the required packages, then list all their required dependencies, download them all, … burn to cd and bring home.

then you must know how to make apt aware of your cd … it’s a mess if you don’t have internet available. I’ve done it like that once for warty, won’t do it again ever.

easiest for you is either to:

  • get someone with knowhow and internet and bring your box over there for treatment
  • get an ‘out of the box’ distro like suse, mandriva … and install from cds.

Hi, it’s me again and this time with ubuntu access.

You need to issue the command:
apt-get --print-uris install binutils build-essential linux-kernel-headers

And you get a list of packages you have to download. It should be about 11 megabytes. On the computer, I had access to, the list of packages looked like this:

'' linux-kernel-headers_2.6.11.2-0ubuntu18_i386.deb 1039142 af9814c9f8d5e5aa538530a15ac11127
'' libc6-dev_2.3.6-0ubuntu20_i386.deb 2821696 8a9f57ed51a49e8e7ea1619e9bf3f440
'' cpp-4.0_4.0.3-1ubuntu5_i386.deb 1986820 dadba9c2a61126808fce35b16adf7b0f
'' cpp_4%3a4.0.3-1_i386.deb 30970 750279e9a9c5213dcbf8de7ff325768f
'' gcc-4.0_4.0.3-1ubuntu5_i386.deb 512640 ffd5a01012a81269443ca057a96ee4ba
'' gcc_4%3a4.0.3-1_i386.deb 5048 dfc1bcea4b13e5d28668f70bc0a1cb67
'' libstdc++6-4.0-dev_4.0.3-1ubuntu5_i386.deb 1470508 6f49dc0b5e5a066996c18afbdf316efd
'' g++-4.0_4.0.3-1ubuntu5_i386.deb 2271092 af1eee74c842df453d3daada62f4d48e
'' g++_4%3a4.0.3-1_i386.deb 1386 aff505809394fa97ca118fbe2121020d
'' make_3.80+3.81.b4-1_i386.deb 286334 984a347383e53e343b4566aa4641ca24
'' dpkg-dev_1.13.11ubuntu6_all.deb 163130 849d2ca5696d0f6eab86579f3bd1c8a6
'' build-essential_11.1_i386.deb 6826 a08a59d3a8ed6c952300762bcb23ebb5
'' binutils_2.16.1cvs20060117-1ubuntu2.1_i386.deb 1406670 4499747cec6bb1463f7b85144d59f466

After you download packages applicable to your installation, you run command
sudo dpkg -i *.deb
and then the nvidia installation should work.

Thank you ondrew, I’m home from school now and I’m going to download those to my thumbdrive. Thanks for all your help!

Wait, does it matter that I use the 64 bit version of Ubuntu?

>>> Wait, does it matter that I use the 64 bit version of Ubuntu?

by all means, yes.

you can screw your installation if you use dpkg -i - be careful with that!

safest bet is to find someone with exactly the same installation as yours, and then fiddle with apt-get listings.

easiest would be just to bring your box to someone with internet.

although you (or someone else) can do
apt-get --print-uris … … > download
wget -i download

and you have the required packages.

Would it do to just download the packets mentioned above, but replave “i386,” with “AMD64,” and leave the rest of the address the same? I tried this, and it came up with a true file, or do I need different packeges altogether, not just getting the 64 bit of the other ones?

Basically, if I just need the 64 bit version of those packages, I’m safe. If not, stop me before I install them.

You really need to execute the
apt-get --print-uris install binutils build-essential linux-kernel-headers
on your computer. You could have a very different dependencies then a 386 computer.

Even if your dependencies would be the same, replacing the 386 with amd64 will not work for linux-kernel-headers which must match with your kernel.

I wouldn’t say the dpkg -i would screw your computer, since the packages you are going to install are for development only.

>>> I wouldn’t say the dpkg -i would screw your computer

I said ‘could’ not ‘would’ - i.e. with using dpkg there is a possibility much larger than with apt, for reasons easily readable on the www. But dpkg is a huge timesaver.

otoh - can someone verify this scenario (thought of it in warty era):

can you just use the live cd (assuming it’s identical to your fresh installation), find and visit someone with a 64bit box similar to yours, mount apt’s cache on a local hd:
apt-get --download-only … packages… (apt-get -d)
burn them to a cd and go home

or (using live cd on some other’s computer):

mount a dir on local hd

apt-get update
apt-get --print-uris …packages…

(copy/paste and cleanup url list in gedit, save to mounted dir as file named ‘download’)

cd to mounted dir
wget -i download

burn to cdrom and go home.

quick reference:

I definitely agree on the dangerousness of dpkg, but what I meant was, that in this case, it’s pretty harmless, since he will be only installing development packages, not needed anywhere else. Even if he installed some weird architecture binaries like SPARC, it wouldn’t break his system.

Other than that is dpkg for experienced users only :smiley:

you are completelly right about that, but it happened to me that seemingly ‘perfectly safe and harmless’ usage of dpkg (checked on another machine) screwed up my non-networked warty installation. I had to reinstall OS, then made the proper dirs/packages.gz for use with apt to check what/where was wrong, had to do some symlinking but - I had a real Debian mantainer and a guy who gives Debian classes to ask for power tips.

If you check my posts, I believe I was mourning here (on elysiun that is), too.

Well, I don’t know anyone with the same installation. Every time I ask someone if they have ay Linux experience they either don’t know what Linux is or they say they don’t want to go through the hassle of getting it to work. My dad is the only one who has a similar installation of Ubuntu as I do, but he knows less about Linux than I do.

Anyways, you guys posted late, I installed the packages that would install (the others said that not all dependancies were met) and I tried installing the drivers then. But now it says that I can’t be running what it called “X server,” while I install them. Is X server the GUI? How do I boot into the terminal only? Even when I login as terminal it still runs some GUI and it won’t install…

Yes, X server is the Gui. You can kill it with a magic and very brutal keystroke Ctrl+Alt+Backspace (close all programs first)

But maybe Ubuntu has this covered and will restart Xserver immediately, so you can try
login and type
sudo init 3
which should kill all programs, but in case it doesn’t work try
sudo init 1

Ok, I’ll try that when I get home from school. Hopefully I can get those drivers working…

Is the lack of drivers why no openGL works?

Is the lack of drivers why no openGL works?

In short yes.

>>> Anyways, you guys posted late
actually you moved too early.

Hello Tynach…

Since you’re in a Blender forum, I’m assuming that you wish to install Blender. If you use apt-get, ubuntu will install Blender 2.41. It will suggest Yafray, but not necessarily install it (as Suse does). Also, you can install Dr. Queue (which will come inreal handy later).
So you will probably need to install Yafray separately.

The fact that I don’t have Internet means that I can’t apt-get Blender anyways, so I’m going to manually install it anyways, along with Yafray.

Edit: This time it let me go through part of the installation, but then it said I was missing files. I think I will apt-get --print-uris install binutils build-essential linux-kernel-headers after all.