Linux hardware acceleration (in blender)


(z3r0 d) #1

I think someone just cringed.

I would like blender in linux to run about as fast as it does in windows. How would I tell blender to do that?

I have a k6-2 with plenty of ram, and a Ge-Force 2 MX (400 I think)
The nvidia drivers are installed and working.

Just blender doesn’t seem to use them.

in one game blender thing I get 4 frames per second (or slightly more), in windoze, and 47 SECONDS PER FRAME in linux.

Please assume that I don’t know much about linux.


(acasto) #2

I’m not really sure, if you have the drivers set up right. Some things to check though are your version of XFree86 and your X config file. Also is your kernel default or did you compile ? There is just so many options and such, it could be many things. If I think of anything though I’ll let ya know.


(z3r0 d) #3

I forget all of you questions so here are some answers

mandrake 8.2 default kernel
x free 4.2 (I think) with 3d stuff

x config file? haven’t looked at it since install

oh, and another thread suggests that I use the dynamic version. I guess I will, and report back

I think that thread was here


(acasto) #4

That might help, because then it will use the more Linux specific librairies supplied specifically for your graphics card.

Other than that, if you want to get serious about graphics on Linux, it would probably be wise to learn how to upgrade and compile your kernel. There is some graphics settings in there that control the agp control and such. I have found for my system, it was best to disable default linux agp control, and set the X config file to use the Nvidia AGP support. There are also some things, such as frame buffers, that can cause stability issues with the system that is best left off.


(z3r0 d) #5

:slight_smile:
Well, yeah but much larger

so, it did seem to fix my problems.
Wonderful, now to solving the good ones…