Linux installation woes (Ubuntu)

//Begin rant
I’m trying so hard to switch to Linux but it seems like every freaking time I try to install something, I need to do an hour of troubleshooting online. And to make it worse, each answer differs from the next.

And why oh why is the latest official Blender version not available from the Ubuntu software center? They seem to have only 2.66 which is ancient :frowning:
//End rant

Anyway, because the software center installed only 2.66 I now downloaded and extracted 2.69 manually. The download page said I should be able to just double click the “blender” file to run the program, but of course it gives me the following error:
“Could not display “blender”.
There is no application installed for excecutable files”

After googling around I saw someone suggesting I go to the file properties and mark it as executable. But the checkmark wont stay on no matter how many times I click!

Is Linux always this difficult? :frowning:

Okay fixed it. I had copied the files on a hard drive. When I copied them into my home folder, I was able to set the executable permission and now its working! Sorry for the rant!

Yep, Linux is usually that difficult. You’ll have to get used to it, and start expecting to do a little-to-a-lot-of extra work any time you want to install something. On the other hand, if you’re interested in doing a lot of compiling from source, Linux can make your life a lot easier. And I suggest not even using the official Blender releases from the software center; just learn how to build it yourself.

People often forget that they have not learned to use Windows in a day, or a month. Maybe not in a year.
You have a little of patience, and you register in one of your distribution forums for get help.
The main problem we had on Linux was related to drivers. Hardware manufacturers did not develop Linux drivers and did not show specifications. Fortunately that has changed much in the last years.
Other issue that is complicating the easy Linux installation currently, is the Microsoft EFI.

By the way, for those users accustomed to a traditional Windows desktop (before to Windows 8), should try a KDE distribution (Kubuntu or OpenSUSE for example).
For low-resource computers: LXDE or Xfce.

No, you use Linux multiple times a day without even knowing.
Desktop Linux? No, easy and fast to install, extremely easy to maintain, easy to use. It’s the Windows “power users” that have difficulties with it because they make a ton of assumptions.

Linux is a lot easier these days than it used to be, and I’m sure it’ll get a lot better in the next few years.
I recommend you use a PPA for Blender. Open a terminal (ctrl+alt+T I think, otherwise just search terminal in the dash) and paste this:
sudo add-apt-repository ppa:irie/blender && sudo apt-get update && sudo apt-get install blender

You will be asked for your root password. These commands will add a new PPA to your sources list,
update said list and then install Blender.

PPAs are pesonal repositories mantained by volunteers who make sure their fav app stays current.
The guy who maintains that PPA is pretty quick, you usually get updates the same day they come out.

You can add a PPA through the Software Center too, but I find it even more cumbersome than using a term -.-

I wouldn’t recommend that.
Blender is pretty much the only application that makes sense to go through the trouble and use it outside the package system. It’s released as self-contained package and distribution package maintainers have hard time getting it to work fully at the pace Blender is developed, which they can’t. Sure it could be dumped in the system as is but why do that when you can get the official release from directly and run as many versions as you need/want, including the development build from the same day.

You can do that to, but the PPA adds Blender to your PATH, menus, sets the mimetype, etc for you.
I keep Blender stable through the package system and then use graphicall builds for the cool stuff.


I’m having a similar problem in Xubuntu (latest version - 13.something?) - I always just unzipped Blender and clicked the executable but now I’m asked for an app to run it (it doesn’t argue about the file being an exe). And it’s doing it for past versions of blender not just 2.69. I tried doing the same as blockrocker but no luck. Any suggestions? Or shoukd I be asking in Ubuntu forum instead?

Tried this after googling some more. Doesn’t work either… :confused:
sudo add-apt-repository -y ppa:irie/blender
sudo apt-get update
sudo apt-get install blender

@Impossible, What error do you get?

Here I had commented what dependencies you need to install on Ubuntu so the official build of Blender can be executed:

@Impossible, make sure you have downloaded and extracted the Blender tar.bz2 file on a partition with Linux native format, eg in your /home.

It took me a few tries with lots of frustration to get into Linux. However when I finally started to actually use it on a daily basis I grew accustomed to it quickly. The main thing you gotta learn to use Linux is to use the terminal effectively and use a healthy dose of Google to solve your problems. There are tons of ways to install software in Linux and it is easy to use the software manager but most likely you are going to have to learn the different ways to install software manually, which can be quite complicated to be honest. However once you get over those hurdles Linux gets quite comfortable to use.

If you, like me, come from a Windows background I can recommend using Linux Mint. It kinda mimics the look and feel of Windows but has the power and functionality of Linux.

I read this 2 or three times and it hits me : “… There is no application installed for excecutable files…(it doesn’t argue about the file being an exe)…”
Did you download and try to run on linux blender pack for Windows ?? Was that blender.exe file you tried to run?

My approach to Linux is to focus on the fun and to avoid the frustrations. It has worked for me since Jan. 2012 but it does not use the latest versions of apps. I can recommend it for anyone wanting to try Linux. I use the live iso downloaded from distrowatch and burned to CD, DVD and USB. I tried dozens of Linux varieties and kept the ones that worked the best. I use Puppy linux_5.4.3 for email and casual searching. I use Linux Mint_14-64bit Gnome for working and processing, mainly adding updated versions of apps to the USBs. I do have Linux Mint_12-64 Gnome on a hard drive because I like the ease and convenience of the file system but I only use this for backing up important files. I try new apps like those on ArtistX and use them live as well. Im working on an Asus AMD motherboard with 8 GB of memory an an FX-4100 processor. I use an USB connected Buffalo DVD and store most files on USB.

As it turned out, during the experiment in which I tried to go back the previous Blender version through the Sofware Center, I was still intalling 2.69 because I had run the command for updating in a previous test. So I just unistalled it again and grabed the folder I had on the HD, ran it the old fashined way (unzip, click “exe”). It worked, so I tried with the 2.69 folder and it worked too. I have no idea what happened. Maybe I just did update the glibc thingy but, if so, why doesn’t the Software Center installation work? shrugs

Januz - this one from the Linux install.

Yafu - Yep, did that too - I had read somewhere about it.

NinthJake -
I went for Xubuntu because it was supposed to be a lighter version that could more easily run on old PCs. I meant to try build a small render farm with a couple of them. I don’t know a thing about Mint. It probably wasn’t around when I started looking for the right version for me.

eppo - I’m fairly sure I was clicking on the icon in the linux folder. I seem to recall ranting at the computer for demanding .exes for a linux thing, but then again my memory isn’t so hot… After that not working, I tried using a windows version through Wine (which failed too).

sword - Wow, you really got all organized. I find I don’t have much patience to do that sort of thing anymore.

Anyways, I’m blending again so I’m a lot happier (even if I don’t know what the heck happened).
Thanks for your replies, guys. :slight_smile:

That’s a really weird error. Happy Blending anyways :slight_smile: