Linux Mint 17.1, Blender not detecting k2100m graphics card.

Hello all,

I am running Linux Mint 17.1 with the Quadro K2100m graphics card. According to driver manager, it is using the nvidia-349 driver.

I have Blender 2.74 and bumblebee installed. When I try and run optirun blender, it doesn’t have the option to use the Nvidia card.

When I tried to install cuda-7.0 from the Nvidia website, it comes up with this message:

***WARNING: Incomplete installation! This installation did not install the CUDA Driver. A driver of version at least 346.00 is required for CUDA 7.0 functionality to work.
To install the driver using this installer, run the following command, replacing <CudaInstaller> with the name of this run file:
    sudo <CudaInstaller>.run -silent -driver

When I run sudo modprobe nvidia, this comes up

modprobe: ERROR: could not insert 'nvidia_349': No such device


I tried reinstalling the driver but it came up with the same error.

How do I get Blender to detect and use the Nvidia card?

Hello.
You share here what you get in the terminal with the following commands:

cat /proc/driver/nvidia/version

sudo dpkg -l | grep -i nvidia

Thanks for the reply,

    cat /proc/driver/nvidia/version 

 
 

returns:

cat: /proc/driver/nvidia/version: No such file or directory


And

    sudo dpkg -l | grep -i nvidia 
 
 

returns:

ii  bbswitch-dkms                                               0.8-1~trustyppa1                                       all          Interface for toggling the power on NVIDIA Optimus video cards
ii  bumblebee                                                   3.2.1-90~trustyppa1                                    amd64        NVIDIA Optimus support
ii  bumblebee-nvidia                                            3.2.1-90~trustyppa1                                    amd64        NVIDIA Optimus support using the proprietary NVIDIA driver
rc  libcuda1-331                                                331.113-0ubuntu1~xedgers14.04.1                        amd64        NVIDIA CUDA runtime library
rc  libcuda1-340                                                340.76-0ubuntu1~xedgers14.04.1                         amd64        NVIDIA CUDA runtime library
rc  libcuda1-346                                                346.47-0ubuntu4~xedgers14.04.1                         amd64        NVIDIA CUDA runtime library
ii  libcuda1-349                                                349.12-0ubuntu0~xedgers14.04.1                         amd64        NVIDIA CUDA runtime library
rc  nvidia-304                                                  304.125-0ubuntu1~xedgers14.04.1                        amd64        NVIDIA legacy binary driver - version 304.125
rc  nvidia-304-updates                                          304.125-0ubuntu0.0.1                                   amd64        NVIDIA legacy binary driver - version 304.125
rc  nvidia-331                                                  331.113-0ubuntu1~xedgers14.04.1                        amd64        NVIDIA binary driver - version 331.113
ii  nvidia-349                                                  349.12-0ubuntu0~xedgers14.04.1                         amd64        NVIDIA binary driver - version 349.12
ii  nvidia-modprobe                                             340.24-1~ubuntu14.04.1                                 amd64        utility to load NVIDIA kernel modules and create device nodes
rc  nvidia-opencl-icd-331                                       331.113-0ubuntu1~xedgers14.04.1                        amd64        NVIDIA OpenCL ICD
ii  nvidia-opencl-icd-349                                       349.12-0ubuntu0~xedgers14.04.1                         amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                                                0.6.2linuxmint1                                        amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                                             346.47-0ubuntu1~xedgers14.04.1                         amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-settings-updates                                     346.35-0ubuntu1~xedgers14.04.1                         amd64        Transitional package for nvidia-settings
ii  primus                                                      20131127-1~trustyppa1                                  amd64        client-side GPU offloading for NVIDIA Optimus


Duplicate…

It seems that your nvidia driver is not loaded correctly (the first command should return information if the driver has been loaded correctly). I have read some people say that in Mint must to blacklist or uninstall nouveau, but I’m not sure. But if you uninstall nouveau now and this was not the problem, you may run out graphical environment. So I recommend you go to the Mint forum and ask there how to make the nvidia driver works on your computer. After you can make the nvidia driver is loaded correctly, you download Blender tar.bz2 file for Linux from Blender site, extract the content to a folder and run the file “blender” there. This does not require you to install extra packages related to CUDA, libcuda1 package only needs to be installed. And do not forget to keep nvidia-modprobe package installed, I see you have it currently installed.

I had already blacklisted and uninstalled the nouveau driver.
The card seems to be working as glxgears runs at 1500 fps while using optirun and around 60 without.
It also runs twice as first using the Uniengine benchmark using optirun.

I managed to get blender to detect my graphics cards after uninstalling everything that has to so with Nvidia, reinstalling nvidia-current, installing nvidia modprobe and using the tar.gz file from the blender website.

hi I’m posting here as I’m on a quite similar issue here.

sudo dpkg -l | grep -i nvidia :

terminal response :

ii bbswitch-dkms 0.8-1~trustyppa1 all Interface for toggling the power on NVIDIA Optimus video cards
ii bumblebee 3.2.1-90~trustyppa1 amd64 NVIDIA Optimus support
ii bumblebee-nvidia 3.2.1-90~trustyppa1 amd64 NVIDIA Optimus support using the proprietary NVIDIA driver
rc libcuda1-331 331.113-0ubuntu0.0.4 amd64 NVIDIA CUDA runtime library
ii nvidia-346 346.46-0ubuntu1 amd64 NVIDIA binary driver - version 346.46
ii nvidia-libopencl1-346 346.46-0ubuntu1 amd64 NVIDIA OpenCL Driver and ICD Loader library

cat /proc/driver/nvidia/version :

terminal response :

NVRM version: NVIDIA UNIX x86_64 Kernel Module 346.46 Tue Feb 17 17:56:08 PST 2015
GCC version: gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)

Do you have a clue on what’s wrong ?
Optirun blender return this :

[ 65.186929] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[ 65.186975] [ERROR]Could not connect to bumblebee daemon - is it running?

I leave a picture so you can see what I have installed.
I leave cuda nvidia 7. I do not think it’s necessary but also install it.
Since installing the driver gave him the 346.xx then install cuda and then upgrade smoothly 349.xx. good luck !!!
Clarification, I have one (gtx 970).


http://developer.download.nvidia.com/compute/cuda/7_0/Prod/local_installers/rpmdeb/cuda-repo-ubuntu1404-7-0-local_7.0-28_amd64.deb

you either have no CUDA-UVM module loaded or one of the UVM related devices has the wrong permissions.
Run any cuda app (or blender) as root and the driver will correct this for you