Lis spider smith program wip


When I tried animating, the animation doesn’t seem to play, there is only a darker colour as seen there in the time line, I haven’t encountered this before.

dark color means the value is the same between the keyframes.

Hi check modificator armature, this modificator need always stay first in up in list, if armature modificator stay down in list animation not working, if this is not work check parenting mesh to armature in object panel - window parent, and check you play action names because action “walk” and “walk.001” not always equal and maybe not working right

Unfortunately, I don’t know anything about that. Smth is simply the walk, and then attack is once the AI is in contact with the player, and then reduces the player’s health, which there is no code for that and same with the AI.

I also couldn’t get the texture to display on the AI, it appeared in windows XP 2.76, a little better than windows 7 which is what I am using, when I tried over two months ago. No idea. I haven’t had this type of problems before, everything has worked concerning animating movements, and texturing, even if a rubbish result. :face_with_raised_eyebrow:

I have now solved the AI animation. A little rough, but it is working. I created a new dope sheet, and key framed using loc/rot? That is working fine. The Ai doesn’t sink through the floor, if use collision for the floor and the AI. So that is sort of stable, but yes, the AI could be a bit taller.

As for the texture, there is no change.

up to date clip.

Pretty sure you’re in Multitexture shading mode (bland UI <3, poor lighting). Use the GLSL shading mode instead. You’ll also need to setup a material, assign it to the A.I mesh, and additionally setup the texture for that particular material.

Currently as it is, I did mess around with that setting, yes, I was trying to see the difference. But that doesn’t matter too much, the texture should display as you can make out in the 3d window there.

Does everything looks okay, if it didn’t work, why is it in the 3d window, but not displayed once the game engine is running?

Have you set the material texture’s projection type to UV instead of the default type, Generated.

In the texture section, I tried generated or UV, that hasn’t changed anything.

I’ve even saved a no material and texture image file, this is how it looks.

You still need to UV unwrap your selected mesh in edit-mode. You know… Providing a blend file would get you faster to the finish line, as we the community can only guess at what we see in the screen-shots and what you’ve told us.

What makes you think I haven’t, why have managed to texture, and now it hasn’t worked?

As you can see, I have UV wrapped the mesh I have textured, moved it around, assigned, and as the video above shows, it loads the texture in 3d window, but once running in the game engine, its as if, I didn’t even add one material. If I remove the material grey, the mesh just has transparent mesh pieces on the side of the torso. So I’ve kept it there for that reason.

If you are in multitexture mode (or the ancient single-texture mode), then the texture is taken from the one assigned in the UV editor when editing a face rather than from the material. So to make a texture display,: go into edit mode, select everything, then in the UV editor, select the texture. I can’t remember if it still exists, but if it does, check the checkbox ‘face textures’ in the material.

If you can, use GLSL mode. Every computer I’ve used since ~2010 has supported it.

Also, I notice your object has multiple materials. Make sure the faces have the correct one assigned by: selecting the faces you want to have a particular material, then in the material editor select the material you want them to have, and click the ‘assign’ button.

I decided to texture the front faces of the leg, I created a new material.004 is was by default, then went to the texture section to add the image, and I named the material.004 as leg.

I then went to UV editor, selected the texture, and began selecting the faces to UV wrap, arranged them, and assigned material to final it. I then load the game, and no texture can be seen on the front or the right leg of the character.

I also did check face textures for the leg one.

Here is an all mesh select, unwrapped in the uv editor. Quite a mess, but this doesn’t load it on the mesh in the game either.

in mesh editor mode you mark seam? press T and select shading - mark seam, just select chains surface, point or edge, this is equal create paper models car or vehicle, and in finish select all surface in you model and press U - unrap, simple method - select all surface and press U - smart unrap and use mode texture painting for model just add new texture in UV image editor and upload somebody textures for brush and use painting to model surface and save texture you model

I tried t, and shear, as for the rest, not sure on the rest of it.

I’ve done what I’ve known and it hasn’t failed. Could it be that because I took it from another file, removed the original texture, it led to this problem?

Painting? I tried texture paint, but this computer doesn’t have a graphics card, but texture paint is what you mean.

Even if I leave the texture side, I still need pointers on programming, everything is setup, it just needs the code, to get the interaction working, health bars decreases, for the weapon it is a bullet that targets the AI to cause damage, in another layer, since the player has a knife weapon, there isn’t any other way to get that to work out.

I wanted the AI to load once the AI has been attacked so that it has spider AI on it, but I tried example files somebody setup, but it didn’t work. The program closed up.

It isn’t just the AI, it is all meshes. I did the exact same process, as you can see the texture loads on the mesh, but in the game engine, nothing.

So I created new material, called it 1, add texture, add image, UV editor UV unwrap, assign it, and then load the engine, and no working result.

Well, I uploaded the file via this file site, so somebody can have a view. I use 2.76.

yes im mean texture painting in viewport and save finishing texture in folder, model not unrap right because no seams in gride model and UV looking how heap, this is not right - with this method, a lot of textures may be required, which will have a bad effect on performance, the second model will be difficult to edit in terms of improving the textures, you can not worry about the ready logic - made logic in BGE, you can always transfer it from object to object and even copy logical blocks and properties, you just need to configure the textures correctly-either draw a texture with a brush on the object or bake it with a highpoly model, I looked at your file the animation was not played because the skeleton modifier with the assigned armature was lower than the empty skeleton modifier, and the animation was recorded only for hand movement the monster. you need to use the action editor to record animations by their names and not the exposure sheet then the monster will have all the animations but with different names-go, expect, attack, all your textures work in GLSL mode and the animation is the same, although it looks like a twitch of the hand, you need to properly deploy this model for textures and write new animation frames - I apologize for such a large text

Hmm, well it has worked so far in my previous files, the same way of texturing. Something went wrong with this.

I transferred the AI from another into the file, may be from the robot file. The animations do work, the AI walks, and does attack the player. The animation is the same from the original, five years ago. There is no real change except for the AI has new legs, and animation for them.

model not unrap right because no seams in gride model and UV looking how heap, this is not right - with this method, a lot of textures may be required, which will have a bad effect on performance,

I don’t follow, what do you mean specifically, is this the scene floor?

I think the model file will be completely fine with those textures, it doesn’t have to as well done as my first one, which I used from the film. So these ones are better, and no copyright. Not that i think anybody would care.

I will add the test file, this was the effect I wanted once the AI has been injured.

SpiderCrawleffect.blend (580.6 KB) Somebody made this years ago

SpiderCrawleffectsmith.blend (2.1 MB) It doesn’t work, just closes up once the game engine is running.