little help please

Quick question, when I try to render an animation it loads a “blinky” type picture but the picture dosent actualy move. I have the Start and end settings as they should be I think. With the start at frame 1 and the end at frame 96 (it’s short I"m still learning) and I know it should move because when I hit alt a in the 3d window it does just as I want it to. I have tried both the play and th animate buttons but neither work. i was doing the tutorial on simple animations but his instructions didn’t cover this possible problem. I have just instaled the lattest version of blender so i dont think its a soft ware problem though it might be. Any help would be great. Thanks.

Okay, here’s a noob-answer:
Are you sure you’re animation on the IPO Curve is also between frame 1 and frame 96? Check also that all your settings are same as in the tutorial.

Better answer: upload your .blend
Then I (or maybe a pro) can check what’s wrong.

I’m sorry that it’s not a very good answer but I’m a noob myself and never had problems with this.

btw: what kind of animation is it?

I do know that the animatin is on frames 1-96, unfortunetly. Thanks for trying though. I would like to upload the file so you can look at it but unfortunetly I dont know how. When i try to attach it it says its an invalid file. If you could tell me how to uplaod the .blend file I would be greatfull. Thanks

You can’t attach .blend files to the err… blender forum, … strange though it might seem.

Try posting your file at savefile.com or any other free file hosting service.

Mike

Hang on a second - Which button are you pressing to render your animation?

Have you told blender what kind of file you want the rendered frames saved to?

If you’re hitting ctrl-A and the animation looks right, then it’s not IPOs or anything like that, it’s the rendering.

Try this as a starting point - Bring up the render buttons and click “Render”

This should create a single render of the current frame.

Come back here and let us know if that worked…

Thanks for all the help. I was suprised too see that this forum is so helpfull. Unfortunetly the single frame renders work perfectly nomater what frame or position the object is in, but the animations dont work still. here is the file if you would like to see it it is just a small .blend file.
http://www.savefile.com/files/2344221 thanks again for all the help.

Ok, a couple of things.

First, I assume you meant the animations aren’t working when you press PLAY to see the resutl (after having pressed ANIM to generate the frames).

If so, there seems to be a bug in Blender that it won’t play .bmp files.

(That is the type you have selected in the format panel labelled (2) in the attached screen shot. If you select any of JPG,PNG, TARGA, TARGA RAW, QUICKTIME, AVI, then the PLAY button will work.

  1. For any output except AVI or quicktime you’re generating a sequence of individual frames, which can be a good thing, but if you want to distribute a movie you’ll need to eventually create an AVI or MOV or MPG file, which can be done either with Blender or an external program.

  2. Except for quick tests, I would not recommend leaving the output panel / output destination at the default of /tmp. If you do, any animation you do will be overwritten by the your current anmiation. And if you render to individual frames, a default file name will be created which can conflict with older animations. And if you change the number of frames, you can end up with a jumbled mess of temp files, so that when you press the PLAY button
    you’ll probably see a random mix of every animation you’ve ever done.

So click on the little “file folder” icon in the output panel, and choose a file name and location for each animation. And as I mentioned above, if you want a “movie” type file that you can view with external programs, then choose AVI or AVI Jpeg or Quicktime (sorenson3 is a good Quicktime “sub” codec. (You’ll see the choices the first time you choose Quicktime, or
you can press the Set Codec button.

See this page for more info

Mike

Attachments


No matter what format I have it save image as (in the format panel of the sceen render buttons) it doesnt work. However the other thing you said was true (if I read it right) the file it holds the temp pics in was flooded with all my previous attempts. So I cleared the file and went again. Now the result is a little clearer. The darn thing is only loading 4 frames. Thats why I only see a blinky picture. Its loading the first fraction of a second over and over again! This is going to drive me crazy! I dont know how to fix this. As I said in my first post I have the start frame set at 1 and the end at 96. So why is it only loading 4 frames? How can I fix this? I realize you all have better things to do, and I am probubly driving you crazy, but any help you can give would be great. Sorry this ain’t working and thanks for everything you have done so far. You are all awsome!

P.S. I tryed it again after I posted this and it only made the first three frames! What the heck is going on?

P.P.S. What program did you use to take that screen snapshot? I can’t seem to find a good one. Although this is definetly not as important as the other thing.

Have a look in those same buttons and tell me what your frame rate is? It should be (by default) 25 frames per second.

“loading” or creating? Are there 96 files in your directory? (I’d recommend jpg or png. Rendering an 800x600 frame = 1.4meg for a bmp and 9k for a jpg !!

Are you running Windows or Linux? Blender 2.42a (I hope as it is the current version … though 2.41 should have no problem … I tested your file with both 2.41 and 2.42a)

I don’t suppose you might have run out of disk space ???

Btw, … and this should have nothing to do with your problem, I would turn off the Shadow, EnvMap, OSA and especially the Ray button for just a simple render test, it will render much faster.

Screen cap, I’m on Windows XP, just press PrintScreen and I used Pbrush to save a jpeg.

Mike

OK - I take it back. Yeah, the problem is as described above.

Try this:

Make the output /tmp\PracticeRender.avi

Then set the image type (Circled “2” in the screen dump above) to “Avi Jpg”

This will save all the frames into a single file with it’s own unique name so it won’t overwrite things.

Question: When you press the “Anim” button do you see each frame rendered in the render window?

(With those settings, 96 frames at 800x600 and OSA-8 with a very simple scene should take about 2 minutes to completly render on a decent machine)

Okay the frame rate is 24 frames per second like the tutorial told me to do. But guess what I was experimenting trying to get it to work while I waited and I hit the “do sequence” button (because neither of the two were selected earlyer) and now I get all 96 frames But there all pitch black, even when I try the single picture renders now it’s all just a black screen. This never happend before, the single pics came out perfect and at least you could see the blinky picture. I’ve tryied adding more lamps and that doesnt work and I know the cameras right. So whats up? I’ve still got 160 free gigabytes on my hard drive so that cant be it. Any ideas? And no the render screen is black too after I click animate. And I tried the other thing you said too but with no effect.

That setting (which is) 25 in his file) has no effect on single-image output.

As for what it “should” be, that depends on what movie format you’re outputting, and/or the effect you want. Although “normal” NTSC is 30fps (29.???) nothing says you can’t output at 12 fps for “slow motion” effect or 60fps for a sped up version.

Mike

As I just posted the fps has no effect for jpg,png, … other single image formats.

“Do Sequence” is not what you want. That renders output from the Video Sequence window … another cool feature of Blender that you don’t need to worry about right now.

You didn’t answer my questions about what Blender version and what OS you’re using.

I doubt it’s this file as it works ok on my system but …

Try starting another file. Just add a cube, unless it’s already there and keyframe it for 10 frames moving across the screen. Choose jpg, or png or avi or quicktime (any and all of those should work). Press ANIM, . the render screen should flash by for 10 frames, then press PLAY … and/or check the directory to see if the 10 files / your movie file was created.

Choose an explicit file name and directory in the output panel (tip , you can create new directories directly from the save dialog … if you put a directory name on the top line that doesn’t exist, Blender will prompt if you want to create it).

Mike

I am on blender 2.42 the new one. I just instaled it. And my os is windows xp. I will try a new animaion and get back to you.

You were right. I am a moron the original blinky picture I was complaning about was just it making the picture’s one at a time. Now I have it back to working properly, thanks to your advice. Sorry you had too be botherd so much by such a noobish impatient problem. Thanks for all you help, you guys were way more helpfull than any other forum i’ve ever been on. This is definetly now my favorite blender site and my favorite forum. Dont worry though I’ll never be that stupid again. Thank You.

No problem, don’t worry about it. I’ve started and stopped with Blender a few times over the past few years, only this year, with the better character animation tools … and many free rigs that I’ve found, have I really started to get interested.

If you haven’t used an animation program before, then even the terminology of “rendering”, “image sequence” … etc, etc, can be bewildering. It doesn’t help either that the tooltip in Blender says “Start rendering a sequence” for the ANIM button, with a “Do Sequence” button directly under it, with an equally confusing tool tip.

The documentation on the wiki is getting much better, the Bsod (lol I know that has to have been a Windoze inside joke) project is a great start.
Hopefully more projects like that will be sponsored every few months.

Mike