Living room (with Updates)

I wanted to try my hands at some architecture and started modelling my parents’ living room. So far, I’m quite happy with it but I don’t understand why the glass door and window ruin my sky texture. The texture’s fine where there’s no glass, as you can see. I have no idea how to fix it. Help, anyone? Please?

Attachments


Can we see the parameters of glass material? :wink:

Of course. Here they are:

Attachments



maybe it needs z transparency ?

Test, test… yes, that’s it! Thank you!!

continues happily :smiley:

Got a little update. :slight_smile:

Attachments


Why does that happen if Z Transparency isn’t enabled? Shouldn’t enabling Ray Transparency be enough?

I have no clue. I’m just happy that it works now. :slight_smile:

… something’s weird. I worked some more on it, and then I added a cylinder (for a flower pot). It never showed up, and I have no idea where it is. I added another one - gone, vanished without a trace. Then I added a third one, scaled it like crazy, and lo and behold, it was waaaaaaaaay down below the grid. I moved it upwards, de-scaled it again, gave it a noise texture, and then Blender went crazy. Preview takes years, Render freezes the entire programm, nothing works anymore. It doesn’t crash, it just responds really slow as if I had added a million polygons, which I haven’t.

Anyone got an idea what I can do? I worked so much on this scene, I don’t want to dump it. :frowning: I deleted the evil cylinder of doom but it didn’t help. I saved the scene into another file but the results are the same. CPU’s working like hell (51 %) but even a 2 x 2 cm preview takes an HOUR to buil (I tried it).

Is it possible to destroy the render engine by doing nothing wrong?

on the upper right portion of blender window, you see a Ve:___, and Fa:___; which basically gives you the number of vertices and faces, respectively. what does it say? is it nearing million vertices or faces?

No, there’s quite a ways to go until I reach the million. It’s Ve: 22336 and Fa: 22393 (makes me wonder how I managed to create faces without vertices). Obj: 150-1 (whatever THAT means). 149 objects? Mem: 17,50M.

No idea? No one? :frowning:

Did you add any new lights recently? Ray tracing gets exponentially harder with each light you add.

No, the only thing I added was the cylinder and the texture. I tried Disp, and then the preview went berserk and shot parts of the mesh into all directions. I deleted the cylinder but maybe Blender still tries to calculate those berserk forms?

If you have been using the autosave options (Save Versions or Auto Save Temp File) you should be able to recover a file that doesn’t have these problems.

Manual page (User Preferences), click/scroll down to Auto Save

I tried Disp,

Check that for using Displacement maps, you need to turn off Normal mapping in the same object. (Nor=0) You can use the two to get weird results, but for this i think you don’t need them.
Another thing: you can use the outliner to select objects you don’t see (if there are any) and delete them.

Cheers!

am not sure if it will help looking at the modifier panel or constraints panel of every object in your scene…(including the offending cylinder if its still there)… there might be “unusually” set parameters… just a guess.

Sadly, I don’t have any un-ruined versions. I checked everything - where do I find the “constraint” panel and the outliner? -, but I find nothing. Still, the preview runs amok.

I noticed that I can click through the five different layers, and the preview won’t update on its own, only when I change the view.

use F7 to go to the “objects” context menu, and look for the tab named Constraints (although, i’m having doubts you’ll really find something there).
for the outliner, Shift+F9 is the shortcut.

are you sure you have no issues with your hardware or drivers? videocard?

I bought a GeForce 8800 a few weeks ago, and everything else (games, other Blender files) works fine. Hardware’s ok, too.

I’m running a test render right now. It’s been running for 3 1/2 hours now. Ok, “running” isn’t quite the right word… Once it’s finished (or I’ll lose patience), I’ll try your shortcuts. Thank you!