Loading Multiple .blend Files & MMB problem

Greetings all,

I am as new as a newbie can be. I just installed Blender less than an hour ago on my Windows 7 PC.

I want to quickly get started rendering an elaborate model that I downloaded of the Acropolis.

Website here: http://es.gnu.org/~littledog/free3d/traducciones/ingles/datos_en.html

[Ack. I wanted to post a second URL to a description page, but was not allowed to :confused:]

I am having a couple of basic difficulties using Blender…

  1. The various buildings in the Acropolis scene are in separate .blend files. How do I load them into Blender altogether so that I can render the complete ensemble of models?

  2. I have a Logitech MX5500 keyboard/mouse setup, and though the mouse does have a middle mouse button that functions by clicking down the scroll wheel, it doesn’t seem to make the navigation functions work. Does anybody else use this setup and what do you do to make this mouse work with Blender?

Look forward to hearing your replies! :cool:

  • Erik

For your first problem, open a blend file in which you want to load all the buildings, click “file” “append” and choose the building you want to append from the correct .blend file.

For the second problem, in the user preferences, “input” panel you can emulate MMB with alt+LMB, the navigation will look like in Lightwave if you know this software.

Still no luck.

  1. When I try the “append” function, and double-click a .blend file in the directory, it expands into a list of folders (Camera, Image, Lamp, Material, Mesh, Object, Scene, Text, Texture, World). When I look in “Object,” there are circles, cubes, and cylinders–yikes! Surely there must be a way to get the entire Acropolis scene into blender all at once, as demonstrated here…

http://heritage-key.com/blogs/ann/free-3d-acropolis-opensourcing-parthenon

  1. alt+LMB does not do anything on my system.

When I look in “Object,” there are circles, cubes, and cylinders–yikes! Surely there must be a way to get the entire Acropolis scene into blender all at once,

That’s the names the person who made the blend file called each of the objects. Why not just select them all (A key), or just seelct the Scene. I assume you installed blender and not actually read any of the documentation before trying to do somethinsg with it. Wiki entry for appending http://wiki.blender.org/index.php/Doc:2.5/Manual/Data_System/Linked_Libraries
For your mouse try selecting ‘Emulate 3 button mouse’ in the user preferences

The problem for these models is that each building contains a lot of objects so you can open each .blend file, select all the objects of a building, create a group (ctrl+G) and save.
Then when you append the buildings, select these new groups instead of the objects.

Alt+LMB doesn’t do anything because as I said in my previous post, you need to enable this option in the user preferences. (“file” “user preferences” “input” and in the top left check the box called “Emulate 3 buttons mouse”)