Lock Camera

I am kind of new with Blender. I opened a file from a previous colleague. They are using a specific camera to render. The other day I rotated (still new) and then lost it. How can I make the camera to be locked and not possible to modify any of its variables. I want to jump from 0 numpad shortcut to perspective without being able to make this mistake again.

Thanks a lot

When you select the camera and open the right panel with N, you see the camera position and location, you can hit the lock in front of each axis to lock it :slight_smile:

See you :slight_smile: ++

Thanks I tried that. I can still press 0 and move everything in that view. But the camera is not modifying the values…not really understanding what is happening.

It seems you get exactly what you asked for, you have to be more clear about the issue.

I am sorry, I might expressed myself wrong.
When I use the 0 numpad goes to a camera view.
Why can I rotate my scene, zoom out and so on…? If the camera is locked?

My point is that I need to continue a job that people were working before and I can not modify that view cause that is the one they use to print the render on paper.

Hope I explained myself better. Thanks so much

If you want the camera view to change you must change the loc/rot of the active camera, unlocking them of course.
If instead you pan/ rotate the view while in camera view, you are actually switching off the camera view and going to custom perspective. Zooming doesn’t affect.
If you hit 0 again, you will get camera view back.

I do not want the camera view to change (responding to your first paragraph), on the contrary I would like to have every time that I press 0 the same view and impossible to modify.

Now when I move within camera perspective…and press back 0 the view is lost.
It does not come back to the desired view.

When these are locked :

You cannot move the camera by any way… So it should solve your problem.

Only possible “problem” would be if the camera is parented to another object or a curve animation, or something. If it’s like that, you should also lock parents location and rotation.

See you :slight_smile: ++

I was attempting to try. I lost my cameras. I added a new one now, but when I press 0 is not the view from that camera. Is there any place where I can pick what camera is my camera view using (0 numpad) using?

I don’t understand what you mean with ‘lost the camera’, it can be either you deleted the camera, or you moved the camera.
In the latter case what @tricotou suggested is the solution.

About your last question, in the N panel of the 3d viewport, under the View label, there is: ‘Local Camera’ where in your case you have to choose the active camera; don’t forget to select the new camera also in the Scene panel for rendering.

Thanks, lost means that either I erase the one I was using or change it.
I might try with some tutorial on internet, I am not getting the result by following the tips.

I pressed the locks as explained by @tricotou and I can still move my camera view :frowning:

If the camera is not selected and you are just looking through it, then changing your view out from the camera should not modify the actual camera. Locking it would just help this situation if it was selected.

Ok finally its working as I expected. I just uncheck ‘‘unlock cam to view’’ . Now everytime I move my camera it leaves the camera view and when I press 0 returns to the expected fixed cam.

Thanks so much. I come from Modo and usually I just press the lock icon.

one more question. My render F12 comes without image. I checked on internet …it says its about the active camera. I have only one camera . How can I make it render what I am seeing in the Camera View
I know I am really annoying.

Edit: solved, my collection was inactive for the render.