locked cameras and lights?


(Abavagada) #1

I am working with a file I have been working with for a long time.
Today, I went to render something, and the light settings didn’t change in the render. Confused, I turned every light in the layer off. Still, it was the same lighting level. Then I tried rendering the scene using a single layer that contained no lamps whatsoever, and the lighting was still the same.

Thinking it might be something with the camera, I then selected another camera, used Ctrl-0 to look thru it, so I knew it had changed, and I was looking at a different camera for rendering. When I tried rendering again, however, not only was the lighting the same, but it was from the camera I had previously been looking thru.

Somehow, it seems, that I am locked into a particualar camera and lighting setting, no matter layer I am on, or anything. And only this filel seems affected. I tried another blender scene, and could change things just fine. Any ideas at all?

And like I said, I have worked this file alot, and changing cameras and lighting has never been a problem before. This just started today.

Aba


(VelikM) #2

Have you tried to import (shift-f1) the scene into a new blender session, does it still lockup?


(ilac) #3

About the camera being “locked” - this is because Blender always renders form the camera called ‘camera’ in the scene in question so if you put in a new camera without deleting the old one, the new one is called camera.001 and so won’t be choosen as the default camera. Solution: delete old camera and then add new one (or rename)

About the lights. Check if you have inserted any ipos related to light intensity. When you press render it will render with the value in the ipo graph. Changing the lamp properties from the lamp properties window won’t get you anywhere if a the value is being controled by an ipo. Solution: Delete ipo!

Do any of these solve your problems?


(Abavagada) #4

Well, you can put multiple cameras into a setup, and then just change which one you render with by selecting the camera and pressing Ctrl-0. You will then be looking thru the camera you selected, and the render will work from that camera. That is so you can set up multiple “standard” shots in a large scene without having to resest a single camera all the time. Problem was that even after selecting a new camera and looking thru it, the render was still using a single camera as the only one to render from.

The same for the lighting. Even after removing all the lights, it was still rendering from a lighing setting I had used. It was like it could only render from that camera and light setting, no matter what I did.

I finally did just start a new file and import everything into it. A few things got put in the wrong layers [happens sometimes on imports], but aside from that, is fine now. Can change cameras and lights again. I can only imagine that something got set in that other file on a global level.

Thanks for the help.
Aba


(ilac) #5

Thank you! I had completely forgotton about ctrl+0 (longish story behind it) and didn’t remember when I read your previous post. Thanks for reminding me. :smiley: