Lockout button for porportional editing?

Hi,

Every now and then my index finger misses “P”, instead hitting “O” while working in BGE. If I don’t catch it,
I’ll transform something, possibly bring a gigantic mess of objects with it, that possibly not even Ctrl + Z could fix!

Gasp! :eek:I know… Maybe a little locker button to the side on the proportional editing button. Disables keyboard shortcut?

I was thinking it would be nice, since I do use it. I just don’t want to use it unknowingly.

What do you think?

I think maybe adding a Shift or CTRL combo in stock would be nice,

I use it all the time, though, so I notice when the text says proportional edit.

I don’t know if you can do this, but maybe you can see if there’s a way to simply remove the hotkey for proportional edit in the preferences window. Sure, you would have to always enable and disable it from the bottom bar, but if you really do not want to deal with the undo function it may be your only option.

the problem is that is near to the P .
time ago i disabled the hotkey too :smiley:

but now sometime i use it : to be sure that not work i do:
elarge the windows 3D until you not ser the icon (ball blue) and so
press O O O O O a bit of time to see if is selected or not.

Roger that, I’ve become wise this buttons game. Like, Marco said, its that it simply happens to be next to P. No biggie, just a little UI topic I suppose. Thanks for the replies.

Why won’t ctrl+z fix it? It undoes everything. And generally, it’s easy to notice the effect straight away.

My suggestions:

  1. Take more care when you press buttons. Nearly all of them do something!
  2. When something goes wrong, don’t try again, undo it immediately and figure out what’s going wrong.
  3. Be observant of buttons, and look for changes.

That said, I do occasionally do this as well. You could make ‘P’ not the shortcut for start the game, and use the menu. (game->start game)


Why won’t ctrl+z fix it? It undoes everything. And generally, it’s easy to notice the effect straight away.

My suggestions:

  1. Take more care when you press buttons. Nearly all of them do something!
  2. When something goes wrong, don’t try again, undo it immediately and figure out what’s going wrong.
  3. Be observant of buttons, and look for changes.

I know all this, its just I have these paddle fingers. When I go in for a key, I usually hit two.
Naw, its not humorous to joke about paddlers. Really its just an idea, I made this little image. Its
something I have been pondering would even be usable. Can you say these additional icons, including
their hypothetical function, do not hold your heart? :slight_smile:

Happy Blending!

This could potentially open a can of worms when it comes to UI options, so you add a lock icon for the proportional edit, but what if people got the impression that lock icons should be plastered all over the UI to lock out any operator that one might accidentally invoke, I mean is there a reasoning why only the proportional edit should get this treatment?

On top of that, if you can disable hotkeys, this icon will only serve to take up space that can be used for more productive operators.

This could potentially open a can of worms when it comes to UI options, so you add a lock icon for the proportional edit, but what if people got the impression that lock icons should be plastered all over the UI to lock out any operator that one might accidentally invoke, I mean is there a reasoning why only the proportional edit should get this treatment?

Completely true, didn’t think of that. My bad.

This is a general problem with hotkeys. If you miss the button you want … you get a complete different result. Sometimes I realize … I did something - I do not know what :spin:

If you go to lock functions … you need to unlock each and everything first ;). This sounds a bit strange. I think when you know that you accidently hit <O> sometimes disabling this key via preferences is a good idea.

Btw. I had the same problem … so I learned what <O> is :D.

I find it more annoying that <P> has a different meaning in Pose mode (and edit mode too). I guess the same solution (redefine the shortcut) will do the trick too.

I think it’s a bit backwards thought.

True, I hit it by accident often and sometimes I don’t even notice it if it’s working with small value and cause actually destruction in my models. But in the end I can’t disable it either because I actually need it quite often.

If you don’t need a hotkey for it, just disable the keyboard shortcut. Blender needs every key to have enough hotkeys for the important tools and I think it’s a real benefit. Keys are next to each other, we can’t have a clear buffer of unused keys around the most used keys at least by default :slight_smile:

Also the lockout-button. As we can see the bottom row with all the icons is already so crowded you often need to scroll it in your UI. Every pixel added there should be very carefully considered and adding this kind of lockout is pretty unnecessary when the problem is about hotkey you can just as easily disable.