logic bounds-cylinder issues

why does this still offer a sphere for bounds?
i’m trying to do a rolling cylinder, but it’s bounds are all wrong.
am i supposed to have the bound sphere totally within the cylinder?

Try the Bullet engine rather that Sumo.
Set in the World buttons (F8) Mist/Star/Physics panel.

Jean

i’m already in bullet.

Then just set the bounds (button in the Logic context (F4) of your object to cylinger and set the Size of the bounds…

Jean

that is what i’ve done.
if you set your bounds to cylinder, and then rotate around the actual cylinder, you will notice that the bounds (dotted line) is the shape of a sphere, not a cylinder.
if it were bounding a cylinder you would expect the options to change the diameter of the bound, as well as the length however this is not the case.
if your cylinder has more width than it does diameter it wouldn’t be a problem, however my cylinder is skinny… like a coin.

I agree that it is counter-intuitive but you just set the dotted sphere to the diameter of the cylider; see this file.

http://pages.infinit.net/bobois/coin000.blend

BTW the 2.41 should be here in a few days with a seriously enhanced Game Engine, bug fixes and more Python.

Don’t loose hope :wink:

Jean

your link didn’t work.
well, i’ll just put up with it until the next release to see if it helps.
the animation i am trying to do will require some pretty amazing
physics, and objects aren’t reacting correctly. i’ll keep tweaking it
until further releases.
thanks for the help.

Sorry, I should have checked. It is corrected now (just the http:// missing)
Hopefully you’ll succeed. :slight_smile:

Jean