Logic Brick Fail Make Cam.dudes Angry

Sometimes, when I add a logic brick it doesn’t do anything. But then I look at that tab in the toolbox window (hit T to toggle) and I see the wrong object has the brick being added to it. I did not type anything in that little tab. This really frustrates me because it is such a stupid tab to have in Blender. If I want to add a brick, I just go and select the object and add it.


Odd, I think that only happened to me when I tried to connect a sensor directly to an actuator (where it then started to bug up the rest of the logic editor until I restarted Blender).

Happens to me tonnes in 2.65. I haven’t tried 2.66

But these days my logic bricks go:

Always -> Python

sometimes when i try to add controllers, these are not added, and they appear after i restart blender, or sometimes on other objects, this is not the worse, the worst part is that when i delete this “randomly added” controllers, they delete themselves and some other random controller, this is kinda annoying cause sometimes i have lots of stuff conected to them and i have to set it up again :mad: