logic brick visualization issue

why in some .blend, I see “all brick of all object”
instead to only the selected obj(one) ?

in BLUE the right, in RED the “wrong”

(how to see only the blue?)


well i think i get what your talking about kinda so first before anything on the left hand side of the logic bricks where it says sensor and then it has four little check boxes to the right of that. make sure all of them are check. Also try hitting A to deselect all the objects then re select the one you want. sometimes that works and also if you have two objects that have logic bricks that are connected to each other it will so all the logic for both objects.

Sorry someone else might be able to help you better Im bad at explaining things.

EDIT: also im not sure if the first solution would make any difference or not but still try it anyways.

Because they are linked, you have to uncheck the link option above each one of the sensors, controllers and actuators

This are inter object logic brick links. They have to be shown.

All logic bricks connected to the controllers of enabled state are visible.
All logic bricks without any connection of the current object are visible.

You can hide:

  • logic bricks not connected to a controller of an enabled state (state check)


I did some tests. YOu have following options:

  • [Sel] toggle logic bricks of the all selected objects
  • [Act] toggle logic bricks of the active object
  • [Link] toggle logic bricks connected to a controller [including bricks without any connection]
  • [State] toggle logic bricks connected to an visible controller (visible state) [including bricks without any connection]

I think you should play with the settings to find your preferred configuration.

ok, got it!
I was able to Reproduce this thing

are the twisted brick,

That is, we can make these plots:

SENSOR (of “cube1”) >>> CONTROLLERS (of “cube2”) >>>>>> ACTUATORS (of “cube3”)!!!

and so joint all
(this way the visualization still strange)

I did not know you could do