Logic panel is not working?!?!

The logic panel keeps getting all weird. Why’s this happening? It usually happens whenever I make a new scene, and sometimes shows up on the first scene.


Go to world buttons, world panel and chose your world setting from your first scene.

greetings, moerdn

It also has to do with what object type you have selected. Some options only come available for certain object types.

I did that before posting, This type of thing rarely happens. @ptbbastos I dont see how the type of object would affect that because I have that same object in other scenes and it dosn’t show up like that.

Go further on your description of “getting all weird”, maybe that will help us understand the issue…

The usual buttons arnt showing up and instead I get the ones shown in the picture.

You might be used to working with a file that you use as a starter or template. And that file might contain objects that cause the various panels to display the required attributes. If you started a new project with this starter file and then deleted one or some of the objects the panels are likely to display in ways you are not familiar with.

this is not a template. It was made a couple days ago by me in blender 2.49

In world settings, change Physics Engine to Bullet.

wow I feel retarded now for not doing that. Thanks :smiley: