Logs disappear when rendered


I am currently working on log burning project. When I render the project, the logs disappear. Any advice would be greatly appreciated. Thank you!

Logs.blend (2.29 MB)

Are you sure it was on the same layer? I can’t open your blend right now I’m on mobile.

Not sure how this happened, but I think some invisible setting tells the object to be invisible when rendered. Maybe this is caused by a setting left over from a particle system (ParticleSystem>Render>Emitter) which may have been active on that object in the past.

However, it seems to be quite easy to get rid of that setting. Just add a new particle system to the object. After this, it should be visible again. If you remove the particle system now, it should stay visible. Good luck :slight_smile:

Where did you get the logs?
Export mesh as ply and import back -this will sort out things.

Alternatively, you can assign the logs’ mesh to a newly created object. Beware of the log’s scale, though.

I think Eppo is on the right track. For some reason, your logs are a “null” object, which usually don’t get rendered. I created a “cube” and applied the same material, and that worked, so it’s not a material issue. It’s something in the object itself.

Ovnuniarchos has it right… Add a new object, then on the object data properties (the triangles), switch to the (null) one. You’ll have to scale it down, but it should work.