Long delay before rigid body simulations starts advancing (Win 10, 2.93.5)

As practice with the rigid body system I’m using it to make realistic shapes of chains in piles, draped over things, wrapped around cylinders. I realize this is the hard way to do this but as I pointed out this is more practice getting to know the intricacies how all of the details work together, especially the cache, etc.

It’s taken a lot of experiments to get it right and I’ve been doing fairly well, but I’ve hit a headache I can’t trace down. Although there have been many instances where the simulation immediately starts, right now I have a problem where the ‘anim player’ is active and Blender is inaccessible for a long time before the timeline even starts moving, at which point it moves along at the same acceptable simulation rate as before. I’m not baking anything and my workflow has been working fine.

Being that physics simulations are so complicated I think it would be easier for somebody to just run my blend file attached. Should be able to just hit Play and watch it think for a long time…the only way I’ve been able to bail out is closing the blender window and bringing up the autosave.
ChainMakerIssue.blend (903.7 KB)

solved! (I think)

  1. sorry, the attached blend file was empty for some reason, but before I could post the correct file I discovered…
  2. Through a variety of copying and pasting into a scene with a leftover cache and various other machinations, I had a stack of unplanned extra and hard to notice chain links occupying the exact same location at the origin and I’m sure the simulation was getting serious digestion.

Lesson learned:
pay close attention to where every single object in a simulation is and whether it belongs or things will get complicated. I only noticed because I had two users for my chain link meshes but I couldn’t figure why because I couldn’t find them because they were in one tiny spot far away from the objects in my scene. (zooming in with the number-pad period key did not get close enough to show anything in my case)

ok, not quite solved, it seems like I have ended up with with objects without meshes, which must be a bug! See my other post about this…

Next time just use normal text…

As you said the blendfile is empty and an image would also help.

Rigid body is i think also end of life and only just supported until they have time to make a new system. Some settings have a high computation output and therefore slow everything down. Always the best to slowly build up the simulations and not just put it on everything.

I worked out the problem and in short the simulation delay was just the sim engine grinding through a bunch of ill-placed overlapping parts because I wasn’t doing a lot of manual steps just right. It’s the kind of thing one might do to work out the exact mechanics for a script so it was getting a little unwieldy, nothing I would attempt to pass on as useful knowledge though. At this point I just wish I could retract this post completely but at the time I was flummoxed!