Long time animator new to Blender, a question on Preferences in version 2.71

I started out with Animation Master/Playmation and have worked with Lightwave extensively and have a working knowledge of Maya. Maya shortcuts are the standard and I’m used to them so I got excited when I found that there was a Maya preset. Well I checked under Preferences/Inputs and the Inputs window is completely blank. Literally there’s nothing there. I’m watching a tutorial video that clearly shows a panel with a wide variety of settings. I work all day long in Modo using Maya presets so I’d love to not have to unlearn all my hotkeys. The non standard shortcuts is the main reason I’ve never gotten very far into Blender. Just too hard switching back and forth.

The question is can you activate this option preferences/inputs or can you load Maya presets from some place since I did find a load command? Really upsetting that they would disable this feature in Blender. I’m sure more people would use it if you could use standard shortcuts. Just kills productivity switching back and forth.

Really upsetting that they would disable this feature in Blender.
No-one is disabling anything, by default the supplied presets are not disabled. If you don’t see anything then there is something wrong with your installation. You need to supply usual info, OS , official blender version, or some special build, are you using latest graphics drivers, screenshots etc etc. Have you tried selecting the preset from the splashscreen ?

I had a previous install of Blender and the panel is the same as the tutorial video except I still can’t get it switch to Maya defaults. I select Maya and then use the set as default and nothing happens. Tried it several times. As to the new version I downloaded it today and it’s supposed to be the current build. The US mirror had a bum link so I used the next one down. I followed a different link this time and I have one downloading from whatever the default source is, I may have stumbled onto a beta build by following another link but it didn’t indicate it wasn’t the current release build. I’ll give this one a try. Still not sure how to switch to Maya since I did try it? I’ll see if I can figure it out again if this download installs better. Here’s a screen grab showing the open Preferences with Inputs tab clicked, it’s blank. The build number is 2.71 with a date of July 08 2014, I did list the build in the top line. Everything else works perfectly just that one window. Everything is current on my machine.

Okay the new download resolved the issue. Also I thought the idea was it adopted all the primary keyboard shortcuts for Maya so I thought it didn’t work. Apparently it’s mostly a few things like left mouse clicking for selection. I want to see if I can get up to speed with Blender. I’ve always seen a huge potential in it but it is hard to switch back and forth. I work very fast and shortcuts are my lifesblood. I’m about to start into a year long project and if I can get up to speed with Blender I’d love to switch. I have some render issues with Lightwave that make it a poor choice, There’s a shadow flickering and texture flicker issue as well as a bug in the antialiasing in shadows that randomly shows up. It drove me nuts on the last project and I never resolved the issues.


The editor in the ‘advanced reply’ has a little button called egochecker. Here’s what your post looks like with that button clicked:

Much better. when you say the inputs window is blank, do you mean that there is nothing under the top line of buttons (Interface, editing, input, addons etc)? Are there several buttons down the left side for various mouse controls with a drop down ‘presets’ menu at the top? To the right of that there should be another dropdown with ‘Blender’ showing as default, and ‘Maya’ selectable from the menu. To the right of it there should be another dropdown with ‘name’ showing by default, and then a text entry field. Do you see all of these?

If you don’t then your installation of Blender is not running properly.Is it possible that you don’t have admin privileges on your computer? Are you running from a sandbox? The info that Richard mentioned would be necessary to know if it’s your build of Blender or your OS causing the problem.

If you are missing the Maya presets you are probably also missing a lot of other stuff, but just in case here is the file from my computer. Unzip and use the load to navigate to it… good luck.


maya.zip (11.1 KB)