Looks Inside objects suddenly come forward... Transparency problem in Eevee, Bug?

Hi, I have modeled transparent object.
There is other transparent objects as well.

The problem is, when I angle the view at certain point, looks like the inside object come forward suddenly.
(as you can see in the captured video below)

How can I solve this?
Did I do anything wrong or is this a known issue?

I’ve set
“screen space reflection” on
“blend mode” Alpha Blend
“Shadow mode” none

materials like this
Front Yellow one

inside bottom white one

I am using Windows 10, Blender 2.91.0

It would be grate if you could help me.
Thanks,

Hi there, do you have Backface Culling on?

Yes, it is on.
But I think it needs to be on and seems it was not a problem,

Searching on the internet, I have found an answer.

By setting these objects’ origin to the same point, this weird problem has been solved!!

So, I guess this is a bug.
I’m not sure this has been solved in the latest version of Blneder, so now I’m installing 2.93.4 one.

https://docs.blender.org/manual/en/latest/render/eevee/materials/settings.html

“As of now Eevee does not support per-fragment (pixel) sorting or per-triangle sorting. Only per-object sorting is available and is automatically done on all transparent surfaces based on object origin.”

Show Backside
“Disable this option to ensure correct appearance of transparency from any point of view. Then using Alpha Blending this option should be disabled because with Alpha Blending, the order in which triangles are sorted is important.”

About “Show Backside”, you seem right.
The manual says it should be disabled when using Alpha Blending…

Thank you very much for your answer.
I seemingly need to study more about Blender.