Looky here what 2.74 did to my SEAMS!!

See the leg on the right? I didn’t make all those seams! What gives?

Running on Ubuntu 14.04, graphics card GeForce 750txi Blender 64 bit.

Attachments


Remove the seams and try again, perhaps you mis-clicked something. That’s all I can think of since I’ve not had any seam problems myself.

Are you using the linux port John? I’ve posted this more in the way of a kind of bug report, FYI. I know how to fix it. I know I didn’t mis-click anything either. This happened when I did a file save and then restarted Blender in order to clear up the cuda out of memory error that’s dogging me too. No verts were selected when I saved the file, and the seams were correct before I saved it. Naturally I checked things with a once-over before I hit Ctrl-S. I probably should have mentioned all of that in the original post. The windows version of 2.74 seems to be working OK, it’s the linux variant that’s giving me issues.

Negative.
See if you can repeat this alleged bug, Mr. Bill. Then we can discuss the terms for a plan that would result in the eradication of this discomfort, if that’s what it is.

Until such a time, further examination of this anomaly is required! Let us hope it is a mere nothing to be forgotten in the void of unseen mistakes.

I’ve simply gone back to 2.73 and everything seems much smoother. It’s a bug, guys, and I am not inclined to register at 40 different sites to report it and other bugs because regardless of what they say, you eventually end up on someone’s junk mail list :wink: .

Anyway, John, since you got involved in the thread enough to imply I don’t know what I’m doing, I recommend you try using the linux port of 2.74 on one of your creations for a while and then jump back in here with an informed opinion.

I suppose you can tell I’m frustrated.

There are no 40 other sites, there’s only one place to report bugs, and this forum is not it. If you want the devs to be aware of it, that is.

You haven’t given us enough information regarding this behavior. I, for example, am using Blender exclusively on Linux, and I haven’t noticed anything strange regarding seams. IOW, you posted a whole lot of nothing about the issue, you refuse to reproduce or report the “bug”, yet you’re happy to declare yourself frustrated.

Nonsense, as my fellow compatriot Stan implied, we simply need more information. At the moment no circumstantial evidence has been provided outside of “it just didn’t work therefore probably a bug.”

You would have had to take the model into a new file and repeat the operation needed for the proper result with the seams. Documentation of the process as well as any specifics you could provide if this alleged bug repeated would have been plenty to confirm and thereafter establish the proper channels for its progress to repair.

Why, Mr. Bill, you could even seek out parts of these forums where other Linux users dwell and seek co-confirmation provided you lay out the details for repetition after the testing I suggested.

For what it’s worth, I think this has to do with something in the python scripts not playing well together (as I mentioned there are other ‘weirdnesses’ in 2.74 that smell like release instabilities which every software goes through) and therefore it is unlikely that the bug will remain for very long. I’m sure the guys working on the release will get things hammered out.

Stan, how much information is there TO give? I gave you the blender version, I gave you the OS, I described what happened and showed the pictures of the result (yes, I even “drew you a picture”). I have noticed that on some open source software forums such as Blender (which I love, to be very clear on that subject), people are routinely attacked for revealing anomalies. I was just trying to demonstrate an issue which I feel is related to 2.74’s changes in the compositing work flow, which if you look at the Blender site you will see is listed as a change with this release.

So Stan, and John, rather than assume it was an error on my part (how in the world does one “accidentally” press Ctrl-E-A?) why don’t you ask specific questions about the information you feel you might need to help determine what might have caused this? If you scroll back through this thread, you’ll see that neither of you did anything other than assume it was an accident. The only thing that even approached this was Stan telling me to duplicate the bug, and he doesn’t even use Linux.

I have used linux 2.74 since it came out, and variants of the gooseberry builds and the occasional daily buildbot build to check for updates. I read your description of your problem, but going by that description I can say that I haven’t had that issue before. Is there more to your recollection of what you did and where you were in the process of working on this model when it happened? Have you had this issue before on other models using 2.74, or is this the first occasion?

I am on linux mint Rebecca at home with GTX 660ti, and I can tell you I used ubuntu at one point on my machine before deciding linux mint played nice with blender, and switched. I have reported a few bugs, some were fixed immediately, and a few were actually outside of the scope of the program and how it works, so they were put on todo list.

Craig, thank you so much for the info on mint. I may try partitioning my TB linux drive and see how that works out. To answer your questions:

Is there more to your recollection of what you did and where you were in the process of working on this model when it happened?
– Yes, this is what happened: I had decided to change the seams on this version of the mesh (I had made some very small changes much further up in the mesh, I had not changed the legs) in order to get better alignment for the UV. In addition to the alignment issue (my own doing) I had noticed that Blender was acting a little wonky when it came to attempting to change vertex assignment for the vertex groups. Some groups that had been in the model for a long long time would not select, and I also noticed that groups which had been outlined by seams had decided to take one additional loop outside the seams, which was definitely not the way they had been originally assigned. Once I made the leg changes and noticed the problems with the vertex groups (I was also getting the annoying “cuda out of memory error” and noting I tried would make it go away) I decided to save the blend file, restart blender and see if any of these issues cleared up. That’s when I saw that blender had apparently decided to assign the entire selection’s edges on that leg as marked seams. 2.74 is the first time I have encountered these issues, and only when I am booted into Ubuntu. I rebooted into the Windows drive where I had also installed the new version, and these issues were not present in that port.

I hope this helps. Thanks again.

Stan,

If you’re not sure, then we can help figure it out, but only if you’re actually willing to participate. As I said, (and as Craig confirmed), there are no apparent issues with seams on 2.74 on Linux. So either you did something really wonky, or you’ve hit some obscure edge case no one ever hit before (or mentioned), or there’s a problem with your mesh, or it’s indeed an elusive bug, or it’s a case of cosmic rays flipping bits in your RAM… We don’t know, and we can’t know until you do something about it.

I’ve been working in telecommunications and computer networking as well as NOC builds since 1985. I don’t believe in “cosmic rays”. I do however understand something about coding, and as I said, this is an issue PROBABLY with the way python is interacting with data blocks. I suspect the problem arose when these improvements were made:

  • Cycles got several precision, noise, speed, memory improvements, new Pointiness attribute.
  • Viewport has new cool compositing features, outliner now manages orphan datablocks better.
  • Modeling now allows custom normals, and transferring data layers between meshes!

I can’t help you any more than that Stan, you’re going to have to think a little bit. See Craig’s post and my response to it for a great example of how to avoid being a thread troll :wink: .

EDIT: You may find this link enlightening. If you haven’t read it either before or after trying to pick me apart, I’d say you don’t have much business responding to these kinds of posts: http://www.blender.org/features/2-74/

Nope, I don’t have to do anything. It’s you who are having an issue, not me. I don’t have your head or your PC or your file: there’s nothing to “think” about. In fact, I don’t even have to reply after all this, but I am replying anyway, because I actually do have one guess, though I’m nearly convinced you’re going to disregard it (or, how did you say, not be inclined?) as well.

Your response to Craig doesn’t say anything (again). All you say is “something got weird and not what I remembered and I was having cuda errors” (latter doesn’t have anything to do with seams at all, by the way).

As to cosmic rays, ok, sarcasm didn’t take, it happens. Where you’ve worked and what you suspect is absolutely irrelevant though, unless your suspicion somehow leads to us understanding the issue at hand.

Now to my guess: you’ve pressed Ctrl+E in UV editor before saving your file. For example, you thought you were pressing it in 3D view, but your mouse cursor was over the UV editor at the moment. You didn’t notice new seams appearing because you were frustrated and hurried to close/reopen the file because of all that “weird” behavior you were getting. How’s that for a bug?

Assuming a bug creates a lot of noise on the bug tracker (a real problem for developers) and on the forums.

Well JA12, I’ll be keeping a close eye on 2.74 to see what “fixes” they’ve made. I’d be willing to bet you folding cash money that this is a bug. Blender is saving a ‘state’ and combining that state with later commands when it should not be doing so. When you’ve been around computers and databases as long as I have been, you get to where instinct alone will tell you when something isn’t right. That’s what’s going on here, at least that’s my take on it. I wouldn’t bother responding if you hadn’t called my action ‘stupid’. We’ll see my friend. I hope you’ll man enough at that time to fess up.

Now to my guess: you’ve pressed Ctrl+E in UV editor before saving your file. For example, you thought you were pressing it in 3D view, but your mouse cursor was over the UV editor at the moment.

That’s not a bad guess, but this didn’t happen because whenever I save a file that I think might be in trouble, I do a “File -> Save As…” so that I don’t save over the original. I also make sure that no vertices are selected as a precaution against breaking the mesh. Correct me if I’m wrong, but I think you also have to press “A” after “Ctrl-E” to mark seams by keyboard strokes. But I’m not wrong. I do appreciate the fact though that you thought this through before responding. :slight_smile:

If you take offense, it’s your problem. We haven’t done anything but tried to help you. You don’t want it - just say so and we’ll all move on.

Just for your information, both I and JA12 (and I suspect Craig too) are following Blender development much closer than you, so thank you very much for the link, but I’m afraid I’ve linked it myself quite a few times; I’ll even clarify, since you’re having big trouble understanding people in this thread: it’s really none of your business to decide what is and what is not my business.

…We also try our best to help people here (and not only here), but it just doesn’t work when people are “assuming, suspecting, imagining, having an instinct” instead of communicating the actual problems in a sane, concise and productive manner. It’s just a thought for you to ponder on.

EDIT: oh, and, yeah, you’re wrong. You don’t have to press A after Ctrl+E in UV/Image editor. It is an operator that marks seams along whatever edges are currently selected in UV editor. Seems to me that either you’re not reading what is being said to you, or not really making an effort to understand it.

Don’t know really, however what was started as an exclamation mark, two sentences and not much technicalities is gone big…
More or less regularly following posts on forum i’m pretty sure nobody’s trying to nail-smash against table anyone here even if it feels so, if this helps to calm waters down.

If i may, i’d like to point that Blender comes different sizes and sources even if 2.74 and after reading the above post: have you ever heard a term “corrupted file” during these years in IT? After software crashes or GPU memory faults (which usually are not damaging files)?

However. Recently i was trying to unwrap and put Ctrl-clicking some seams around heavily sculpted in Dyntopo monkey head - i’ve got a lot of random individual edges where seam was absent after file save and reopen while initially seams were fine - your mesh seems dense so that there might be something in common. I’m using Mint 64 bit for the protocol. Unfortunately i can’t tell Blender’s build now precise - GB branch from couple of weeks around. I did not report since this is surely not the proper way of unwrapping. Maybe i should have had to.

That won’t be necessary. Best of luck with your current and future endeavours.