LoopTools 2.4 - help, please.

So, I’ve started this face, trying to get the loops correct,

But that’s resulted in a bit of messy mesh. Meshy.

So, I remembered Loop Tools, and thought that would be a way to help me tidy it up. I know the mesh is unfinished but I hoped Loop Tools would help to even things out and sleek my lines.

The illustration bellow (sick) is just an example of one of the many things I’ve tried, here spliting the vertices on the outside end of this “loop” in a vain attempt to get Loop Tools to agree with me that it is indeed a loop, and that it should curve it like I bloody well asked it to.

But it won’t. I am misunderstanding what Loop Tools does.

Could someone please explain where I’m going wrong with Loop Tools or suggest another means of aiding my attempts to tidy this mesh.

I’m happy to start the mesh again from scratch if Stoopid Tools (sorry, I don’t mean that.) can help me model a bit more neatly.

Please and Thankyou.

http://img85.imageshack.us/img85/1153/helpc.jpghttp://img233.imageshack.us/i/helpb.jpg/

Hi, I’m the creator of Stoopid Tools ;).
I just tried to reproduce your case, and you’re right: the script doesn’t recognise the loop correctly. The reason is probably because I made an assumption on the vertex indices that isn’t true when a mirror modifier is added to the mesh. (You do have one added to your object, don’t you?)
I’ll release a new (fixed) version of the script later today in this thread, but a quick fix for now is to disable the mirror modifier when you use the script.

ps: you’ll probably get better result by selecting the red vertices, instead of the green ones
http://img269.imageshack.us/img269/5417/helpco.jpg

Sorry, again, for calling it Stoopid, I’m in no position to criticise and was frustrated, but it evoked a rapid response, didn’t it?

Thankyou for that, glad I could help find a “bug”(?)/glitch. Haven’t done that before.

The mirror modifier is on, yes, and I thought that might be the problem having read through your Loop Tools thread yesterday.

Thankyou, thankyou, thankyou, again. I’ll be sure to credit you in anything I do with this …thing.

Loop Tools everybody:
http://blenderartists.org/forum/showthread.php?t=148728

No need to apologise for criticising me. I actually had to laugh when I read the new name for it.
The new version (2.4a) is now available in the main LoopTools thread.

No, no. I wasn’t criticising: I can’t.

Thanks again.

edit:

Oh god. Am I going to go the other thread now and find it renamed?

What have I done?