Losing imported colour

Hi Everyone

I am importing from Sketchup to Blender using the sketchup importer script. If I want to edit an imported solid diffuse colour i.e. to make it glossy, I first have to enable nodes in the material editor. As soon as I click on ‘use nodes’, the original imported colour changes to the default white base colour and I lose the colour I needed.
Is there a way around this?
It doesn’t happen with an image texture so is the only way, to make the sketchup material based on an image of a colour so that it gets imported with an image linked to it?


Before activating the nodes, you can click on the color, go to the “hex” tab and copy the code. Then, you can activate the nodes and paste that code into the material’s color slot.

Alternatively, materials have a preview color in their settings, in the “viewport display” section. If that preview color is the same as the main color, you can just get it from there (you can literally drag and drop the color between the 2 slots).

I don’t think there is a better way to do it.
In fact, it’s a bit weird that there is even an option to deactivate the nodes, as there is no point to do it since the internal renderer was removed from Blender years ago.

Thank you, both good methods. I didn’t know about the drag and drop option which is certainly the easiest.
Thanks again

1 Like