Lost ability to go into Edit Mode


I have downloaded and installed Blender 2.4 and I am using the 2.3 book. When fiddling around with the 30 + 30 minutes tutorial I seem to have lost the ability to switch between Edit and Object mode … so I’m ‘stuck’ in Object mode now :o . Even if I save and quit and then restart Blender it does not change anything. Of course I could start another piece of work and forget about it but I’m quite sure that somewhere in the future this will happen again. And then it will not be a tutorial but some serious work. And I do not think starting all over again will then be a great option :mad: . Could someone please explain why you can get ‘stuck’ in Object mode and how to undo it. Please remember, I was fiddling around and trying to familiarize myself with the interface so it is very well possible I did something unthinkable, but I just would like to know what can cause this to happen.
Thanks in advance ! (Anyhow: Blender is fun! :smiley: )

Upload the file at www.savefile.com or www.megaupload.com.

Could someone please explain why you can get ‘stuck’ in Object mode

Too much beer? You probably have a Lamp or somesuch selected, or Active (light pink) if you have more than one object selected. Lamps and Camera don’t have edit mode.


Not enough beer merry xmas.

I have uploaded the file to http://www.savefile.com/files/362170

Also I checked the selections and the camera/lamp, but whatever I select or deselect (using AKEY) does not change anything.


Your file goes into edit mode ok for me, has your tab button on keyboard stopped working,can you go into edit mode by using clicking the mode selector instead of using the keyboard.

Wow. I tried out another keyboard but no changes. I already tried the mode selector and found out that nothing changed. Then suddenly … it worked again. But what was the difference? The ony thing I found out after trying to rewind my actions was that I selected the object (‘Gus’) with RMB (Right Mouse Button) and that seemded to do the trick. Also the buttonpanel below came back to life again. And even if I then unselect everything (like as it was when loading the file) then the Edit mode stays available.

So I guess that I’ve entered some dead end in the code (requiring a u-turn) or it is a feature that I’ve not encountered yet in the documentation :confused: .

Hazza, is this RMB thing the same as you did to persuade Blender to go into edit mode?

Thx for your support so far ! :smiley:

Yea you have to select the object with RMB to be able to go into its edit mode, else when you have more then one mesh object blender would not know which one it is that you want to edit.