Lost my connection from Armature to Weight Paint?

I have been working on a project and seemed to have lost the connection for lack of a better word,
between the armature and the weight paint on the mesh…it was working…now the armature is disconnected from the mesh when in pose mode?
if I select>>>>armature>>>>pose>>>highlight a bone>>>object mesh>>>weight paint…
the weight paint is still there for the bone? I have tried re-weight painting the area and have checked the vertex groups which all appropriately cycle through showing the proper weight paint and still no connection to the armature?
any ideas? Thanks!

Two guesses:

  1. You have the rig in rest mode, in the armature data tab (the little man(rig) icon) click ‘pose’ instead of rest

  2. You have deleted the armature modifer, or removed the armature name from the modifier. If you do still have the modifier, make the name of the armature is selected, if you don’t have a modifuer, add one and select the armature name.

Posting the blend will help.

The armature modifier is there and selected object is armature. Under armature data tab it is in pose.
The blend file is 288M. Its an animation is there a way to just export the object with the armature settings and weight paint? It would not let me upload a .obj file

sorry I just check and the armature is not exported in obj file.

You could try starTing a new blend, file append, and append the character object into it, I think the armature will come with it. If there’s a ton of animation you could go into the dope sheet and delete everything.

Thanks Photox that worked. I hadn’t worked with the append option before I have attached a link to the blend file.
http://www.pasteall.org/blend/36400

Short answer: You have disabled the armature modifier in viewport. In the armature modifier click the eyeball icon.

Long answer: You can move forward and weight paint, etc… but really the mesh needs to be retopologized using less dense quads. It’s one of those things where if you try and weight paint it now, you will be forever tweaking, and it will never work right, and your shading will be off. Better to bite the bullet, retopo it, and the bonus is that you probably won’t need to do much, or any, manual weight painting on the retopo.

hmm ouch retopolizing seems painful lol Is their no other way to reduce the density of the quads?

Not really. For starters, you have no quads. A quad is a face defined by 4 verts and 4 edges. You have what is called triangle soup, usually the result of dyntopo sculpting. It’s fine for static meshes that won’t be rigged, like a statue.

hhhmm I understand…guess I will be retopo’ing Thanks Photox