loudspeaker rft br25

Hi there!
I modeled my rft loudspeaker. Only the srews at the tweeter and the woofer are missing.
I want to texture my speaker that it looks realistic. What is the best way to texture it, make photos myself of the speaker and texture it with these or how can I realize a texture that looks real?

Attachments



Great render! To get it realistic, you may wish to try some external renderers like Yafaray. These are quite tricky to get installed, but if you have a look at their outputs, I’m sure you will get some nice ideas.
Your approach of taking a photo-graph and texturing this in can work too, although you may have to spend some time in setting up the lighting setup, bump maps and so on.
Personally I would get Yafaray installed, download one of many free files blender Yafaray specific out there with a good light setup, study this and then append your speakers to this. No use in reinventing the wheel twice, unless you want to learn how things work for future reference.

2 cents*

often in 3d there is the addition of wear marks, scratches and imperfections, to add realism.

a5’

Thank’s for the suggestions.
I shoot the loudspeaker with my cam. Now I want to take the textur on my 3D-model. In Edit-Mode I selected the vertices that I want to texture. In UV/Image Editor I opened the textur on the selected vertices. In textur-mode I can see the texture on the speaker but when I render the box, there is no texture on it!
What can I do?

Attachments


nice aggregats !
high quality mp3 T.I. - abcmuzic.com :slight_smile:

I think this is what you want.

manual >texture options

a5’

a59303 thanks for your reply.
I took my texture at the UV/Image Editor on the selected vertice. Then I can see the texture at the 3d View, look at my last post. Now I saved the image at the UV/Image Editor and load it as texture on my box (F6), texture type: image.
The problem is, that the texture is on my whole box (look at image), not only on the selected vertices!
What’s the best way to get my texture only on the selected vertices?

Attachments


Use multiple materials, one for the case, tho other for the actual speakers, or seperate into 2 objects 1 is the case and other is the speakers, and give them 2 different materials that way.

Not sure but I think you wantmaterial indices.

But I think I may have steered you wrong;

Try this,
start a new default scene (cube in center)
switch on the texture for viewport shading
enter edit mode with the cube selected.
go to UV editor, and load image. That should get you to see the image on the cube, in the view port
go to the texture area, asign texture (image) then under mapping set the coordinates to UV.

Play with that, I think that should get you what you want.

a5’

DDD, a5’ thanks a lot!
I gave the loudspeaker-box the material I photographed. After them all objects had the same material like the box, I don’t know why, maybe the box is like a parent of the other object’s?! Also there are stripes of the texture on the box but on the photographed texture are no stripes! What are useful options to link my texture on the box? I can select only the woofer and link the matieral of the woofer to it. But after this the tweeter and the bass reflex port have the same material like the woofer!
Is there an option in blender where I can see a structure of the objects and how they are linked together?

Attach Files: stripes at texture, wrong texture of woofer on tweeter and bass reflex port, original texture

Attachments




The lines on the box are, like the grains in wood, they are actually the image mapped *through the image. Try using cubemapping although this will negate the earlier use of UV coordinates that I, as well as you, mentioned.

The outliner will give you hierarchical info

a5’

a59303 thanks for your reply.
Your post helps me a lot! I solved my problems.
Last not least I want to get my photos at the right position at my model. Therefor I selected the object and unwraped it in edit mode. In the UV/Image Editor I adjust the unwraped model at the position where it should be. In 3D-View I can see the result on the fly. At this realtime view the texture is on the right position. After that I render the Image but then the texture is not on the right position, it is on the same position like I don’t unwrap it.
How can I solve this problem?

Attachments


Sorry for my tardy reply (late) I was in a funk:(, anyway, I think the problem is that you didn’t assign the material which has the UV coordinates to the object properly. Not sure, could you post screen-shots of the material pane and the texture pane… particularly those parts which have to do with; ‘Coordinates’ and ‘Projection’ (Texture Pane).

a5’

Sorry for my tardy reply (late) I was in a funk:(
No problem :wink:

I solved my problem at this way: I used separate texture pic’s for each object. It works. But I’m dissatisfied with this solution! At the attechments: sceenshot form material pane and texture pane.
Where can I manage the coordinates?

Attachments



Alright, I was unsure about the version you were using;

in the material pane-- there are tabs Map Input and Map To. The Map input is what I was talking about. Both should be useful to you though.


Ok, now I know what you mean :spin:
But what’s the right adjustment?

Attachments



Oops. I think I steered you wrong again. The UV button in map input will tell the material to get mapping info from the UV map, then I think you may have to choose which map.

a5’