Low poly models with soft edges impossible?

Hi there,

this is my second post for today but baking normal maps drives me insane currently. I just want to bake a normal map from a highpoly model to a low poly version of this model. The model has some hard edges that are a little round but the low poly model only has sharp edges there (two faces are connecting and creating razor sharp edges). Now i try to get to a satisfying result since hours without any success. I wonder if it is simply this hard to create soft edges, if i miss any detail to achieve this or if it is simply impossible …

To keep it simple i created a cube (Blender 2.78a) and applied a bevel-modifier to get round highpoly-edges. Than i created a second 6 sided cube - the low poly version. Then i marked every edge sharp and as seam and unwrapped the low poly. Every face became its’ own uv-island to avoid bleeding between sharp edges. Then i created a cage from the low poly wrapping around the whole high poly and baked the normal via cycles and the cage-checkbox activated (of course i applied the cage there). The result where really bad looking edges. The hard edges where still visible. I watched several videos and tutorials about this and their results where much better even i did the same steps:

Normalmaps in general:

Smooth/Flat shading while baking normal maps:

I tried baking via Blender Render, Cycles and XNormal but i never got really good results as seen at svartberg.com for example (second link above).

I would really be thankfull if someone could explain me what iam doing wrong or if it is simply not possible to get better results … I attached my test-project from the screenshot below. Maybe someone could create these soft edges so i can see how it was made.

Thank you guys!


EdgesTest.blend (677 KB)

It looks like you didn’t bake with a margin. Have you tried setting the margin to at least 2 pixels in the bake options ? Note that you can set it as big as you want, it won’t make any artifact as it will stop propagating when 2 parts meet.
Personnally I get perfect results, but only when I set a margin.

Otherwise, it might be that your light is oriented to have a terminator artifact :

which is something Cycles hasn’t solved yet (but Internal has). But from what I see, I doubt that’s the the cause of your problem.