Low viewport FPS with dual xeons


#1

Hello, my first post. I’ve been using blender since April 2018 I decided to switch from 3ds Max which I have been using for many years.

Anything I attempt to animate other than basic shapes plays in the viewport at 5-10 FPS. For example I can load the “victor rig” (20,323 verts) from blender foundation and simply click ALT A, and it runs at 9 FPS with no keyframes animated).

My set up is a dual xeon total 20 cores @ 3GHz each GTX 1080 and 64GB ram. all drivers up to date. running Windows 10 Pro.

I’ve googled this and have tried all of the suggestions I’m lost but don’t want to have to go back to 3ds max to animate.

I have this issue in both v2.79 and v2.80 beta any help will be greatly appreciated.

In the comments of the Victor rig, Juan Pablo Bouza says he can get it to run at 24FPS on an i7


(yogyog) #2

You can probably get the framerate up if you disable a few things. I’ve not looked at the victor model, but if you select his mesh and go to the “modifiers” tab, they’ll be a load of mods you can turn off to increase framerate such as particles (his hair) and subsurf.

There’s also a panel at the bottom of the Scene buttons called simplify that allows you to turn down subsurf across the board.

There’s also a dropdown on the timeline that by default is set to “no sync” … but either of the other options is way better.


#3

Thank you for your response, unfortunately I’ve tried all of this even with simplify checked and viewport subdivision set to 0 and AV Sinc all particles disabled I still get 9 fps. I’m using victor as the example because no matter what I create the blender viewport just runs slow (unless its a few cubes) I’ve spent months learning blender creating complex scenes and characters paying attention to poly count and modifiers, now that I’m in the animation portion, i feel sick that I cant get any of my work over 10FPS. No matter what I do it’s unusable. I don’t want to have to switch back max/maya because I got so comfortable with blender. rendering is fine and fast just viewport performance is very bad.

when blender animation is running @5-10fps, windows CPU+GPU is under 10% memory is <15%

I went over every single setting in my:
BIOS
NVIDIA panel
Win 10 power settings
Blender user preferences>system
updated drivers
cinebench benchmark is good 2832 for CPU and 68 fps OpenGL

Has onyone had a similar issue? anything else to check? or is this just how it is?


(Leumeister) #4

I’ve heard that using BlenRig, which is what Victor is rigged with, is very resource intensive. That could be the issue. I might be wrong though… I haven’t used BlenRig since learning about that particular pitfall. :stuck_out_tongue:


(birdnamnam) #5

This is fairly low imo. A modern i7 or i9 paired with a 1080 should give more than 150 (close to 200) fps in Opengl test. One of the reasons could be the very low Single Threaded performance of the Xeons you’re using. STP is a paramount factor for viewport performance. Could you mention the Xeon’s version you have?


#6

Thank you for your responses…

I’ve heard that using BlenRig, which is what Victor is rigged with, is very resource intensive. That could be the issue. I might be wrong though… I haven’t used BlenRig since learning about that particular pitfall. :stuck_out_tongue:

This is the case for my personal rigs (basic rigging without BlenRig) ) as well. I was just using victor as an example sine I figured lots of people here may have played with it.

This is fairly low imo. A modern i7 or i9 paired with a 1080 should give more than 150 (close to 200) fps in Opengl test. One of the reasons could be the very low Single Threaded performance of the Xeons you’re using. STP is a paramount factor for viewport performance. Could you mention the Xeon’s version you have?

Agreed, I’m using 2 e5 2690v2’s 3.0 Ghz 10C/20T with turbo to 3.6Ghz.

For further analysis, my viewport and rendering run ultra fast, it’s only when I click “Alt A” on a basic rig that everything comes to a screeching halt of 9fps.

I did some testing, the same rig runs over 24fps on my imac (i5 4570R 2.7ghz QC 8gb ram) and even my old windows laptop (i7 3537U 2.0ghz DC 12g ram)

I’ve run intel diagnostics tool on processors all pass.

I’ve tried disabling turbo boost, hyperthreading and cores, all nvidia options and fps doesn’t budge 1 number. Processors and gpu stays cool and have no stress when clicking “Alt A”

I just installed Linux on the same machine to see if it was perhaps a win10 issue, I barely gained 2fps when hitting Alt A on Victor rig.


(birdnamnam) #7

The STP of this Xeon is really… underwhelming. Only 75-80cb in Cinebench R15 Single Core, when modern cpus range from 160-170 to 220cb. You can’t expect much more from these chips. Just in case, what are your power settings in Windows? If you are set to “Balanced” try “Performance” and see what’s happening.

Also, have you made all the necessary tweaks that help animation in general, like checking the “Frame Dropping” option in the Playback menu? Do you have more than one viewports open in you screen while playing animation? Having multiple windows open, or even the timeline window etc. slows down the active animation viewport.

Hope this helps. Can’t think of something else.


#8

Yeah, my Single core CB score is 114, I have windows power settings and everything else set to performance even in the BIOS. Looking closer at the victor rig there was a mask modifier that when disabling it boosted FPS up to 19. Also I noticed in another personal rig that even though a boolean modifier was disabled in viewport it was still killing fps unless I deleted it (not sure if this is a bug). I’m having hope I can get my rigs to 24fps with little tweaks etc. Still disappointing that my workstation can’t handle animating better than my lower end computers. I was hoping there was just some magical setting I was missing.

Thanks for taking the time to help and shed some light on these issues.