Lsystem (Tree maker)

Please , help me. The Lsystem script doesn’t work correctly. It works OK when I switch off the option “Add Leaves”. But if I switch on it I get such message:" AttributeError: ‘module’ object has no attribute ‘Const’". Please , help. How can I make it work right , bacause the tree without leaves doesn’t look very nice.[/b]

What are your system specs?

OS
Blender Version
Python Version
Script Version

That happened to me with v1.1 whenever the default leaf was changed. Try the updated script by jms here:

http://jmsoler.free.fr/util/blenderfile/images/lsystem/neo_lstseed228.zip

%<

My operating system is Windows XP Professional. Python 2.2.2 , Blender 2.32 (but it doesn’t work in no one from 2.25 to 2.32 and all releases) and its version is 1.20 but I also tried to use older version but I got the same result.

There is no version lsystem 1.20, just lsystem 1.1 . Tested on blender 2.32 and win98, it works perfectly if you choose the application.py script.

I found a version 1.2 of the lsystem script at http://www.geocities.com/blenderdungeon/lsystem/index.html

granted - the link didn’t say that it was version 1.20, but the script itself had that number in the header.

Also - I tried to reach the author by emailing the address listed on the site at the bottom of the page I had quoted above, but it wasn’t active anymore. Does anyone have a current email (or know what their nickname here is)?

Tim

Okay - I think that I found the bug. On line 61 of lsystem.py there is a line:


61: C = NMesh.Const
62: # print C

I think that this was a debug statement or something. The variable “C” is not used anywhere else in that file. If you comment out that line (or delete it) the script should work. Save your blend file, close Blender, re-open it and run your script. It worked for me …

I am using:
i386 architecture,
Debian Linux 2.4.22xfs,
blender 2.3.2-1 from the Debian Unstable branch,
local python 2.3.3 (I have no idea if it is the one that Blender is using though, probably not).

file date : 14/01/04 a really recent .

Just a note, lsystem has just a little problem : you can not get twice the same shape with the same data but the file you can download at this address
http://jmsoler.free.fr/util/blenderfile/images/lsystem/neo_lstseed228.zip
has a “fixed seed” option for this.

Hey all,
I’ve been having problems with lsystem. When I set my parameters, and push generate, blender returns an error saying that lsystem_build isn’t defined. I’ve set all the required paths, but can’t find any reason for this error. I’m running win2k, blender 2.32, lsystem 1.1, and pythong 2.3. Can anyone help with this?

Paul

needs to be Python 2.2

I think within the next 1 or 2 updates of Blender, it will finally be updated to work with Python 2.3 (then I can tell everyone "you need 2.3 not 2.2 :expressionless: )

my problem is that i can’t get no leaves with this lsystem script ???
why ?
does it exist a tutorial ? (another one than the one on the blenderdungeon page of the lsystem script)

or another kind of script to build trees ?

thx

Did you activate the leaves buttons? ( bottom right of the interface. )

http://marief.soler.free.fr/Monsite/lsystem_fr.htm

Sorry, the english version:
http://marief.soler.free.fr/Monsite/lsystem_en.htm

Did you activate the leaves buttons? ( bottom right of the interface. )

yes modron this button was activated …
but it wasn’t working and i don’t know why ???

it’s ok now … thx :stuck_out_tongue:

http://marief.soler.free.fr/Monsite/lsystem_fr.htm

thank u jms good tutorial …

woohoo the 2.28 version works perfectly

Question : is there anyway to make this script activate the generate button after every adjustment of a slider. It could be so much faster to play with testing and fine tuneing it this way. The computers I have it on are fast enough to take the hit if I give it to much of a calculation load.

:slight_smile:

amen to that.

Martin

amen to that.

Martin[/quote]

:expressionless: what does that mean. I was just asking :expressionless: