Ludwig Armature implementation: Blender noob totally lost!


I’m sure this will make you laugh, but I’m new to Blender (coming from Maya) so I really could use some help here!

I added the Ludwig rig to my project to implement it with my own mesh. I had to make changes to the bone size here and there, no big deal.
The problem is that when I switch the armature from edit mode (in which it fits my mesh perfectly) to the object mode (or pose mode) a lot of bones lose my edits, going back where they were originally. How this can be?

Any help?


Well, judging from the answers here I guess my question is not that trivial… so should I gather that there is no way to make the Edit Mode changes globally valid?

Hi PinoEire,

I saw your post and honestly, I don’t know how to add an existing rig to a mesh, I just create a new one. I was watching some videos on animation and one covered this subject.

Hope this helps,

Hi Randy,

thank you for answering. Actually I’ve done exactly that way, well, omitting the copy of the blend file containing the armature: why one should make a copy before to append from a library? AFAIK there isn’t any reason.

I’m slowly sorting it out making all the changes twice (in edit and in pose) but it’s kinda depressing that way…


The idea of making and renaming a copy before you start work would be so that you have the original rig/character available for use later. As to why you are making changes in both Pose and Edit mode, I’m lost. Why? Pose mode is for animating the character and has nothing to do with rigging the character.


Well, I don’t make any copy of libraries and use them in different projects: the original stays the same, not altered.

The changes in Pose mode are forced because the pose mode doesn’t take into account all the changes I made in edit mode, so the mesh is messed up.

Hi PinoEire

can you post the file you are having problems with
if it’s too big PM me and I’ll have a look at it

also what version of Blender are you using?
I’m assuming 2.49b

I’m just guessing, but hey, it’s worth a try. When you are in Pose mode, try clearing the location (Option G) and rotation (Option R) of all the bones. That way the bones return to their original position. Now go back to Edit mode and change things around. Then go back to Pose/Object mode, and the bones should inherit the edits. I just tried it and it seems to work (using 2.5 here).