LuxBlender script won't enable

Hi

I have downloaded and installed Luxrender. Everything is working fine until I have to enable it in Blender 2.62. When I go to the Addons tab in the User Preferences window, I go to Luxrender and try to tick the box but it won’t enable.

Pls help. I am sure I am missing something very simple.

Thanks in advance
blendercrazy

UPDATE: The script enabled but I couldn’t see it in the render options. After disabling the script again, I can’t enable it. Please help.