LuxCoreRender 2.0


(Floki) #61

Hi thanks for reply, just new scene with cube lamp and camera. Tried to open different scenes, but the error always just changed the numbers in the texture name.


(Floki) #62

here error from terminal
view_update
new session
exporter init
create_session
[SDL][9.908] Camera type: perspective
[SDL][9.908] Camera position: Point[-10.4796, -20.2917, 8.3734]
[SDL][9.908] Camera target: Point[-10.0359, -19.4459, 8.07706]
[SDL][9.908] Camera clipping plane disabled
WARNING: Object “Cube”: No material defined
[SDL][9.909] Texture definition: __grid_10cm_1
exporter init
ERROR: Syntax error in texture name: 0.4 0.4 0.4
Traceback (most recent call last):
File “/home/floke/.config/blender/2.79/scripts/addons/BlendLuxCore/engine/viewport.py”, line 19, in view_update
engine.session = engine.exporter.create_session(scene, context)
File “/home/floke/.config/blender/2.79/scripts/addons/BlendLuxCore/export/init.py”, line 105, in create_session
luxcore_scene.Parse(scene_props)
RuntimeError: Syntax error in texture name: 0.4 0.4 0.4
view_update
new session
exporter init
create_session
[SDL][9.919] Camera type: perspective
[SDL][9.919] Camera position: Point[-10.4796, -20.2917, 8.3734]
[SDL][9.919] Camera target: Point[-10.0359, -19.4459, 8.07706]
[SDL][9.919] Camera clipping plane disabled
WARNING: Object “Cube”: No material defined
[SDL][9.920] Texture definition: __grid_10cm_1
exporter init
ERROR: Syntax error in texture name: 0.4 0.4 0.4
Traceback (most recent call last):
File “/home/floke/.config/blender/2.79/scripts/addons/BlendLuxCore/engine/viewport.py”, line 19, in view_update
engine.session = engine.exporter.create_session(scene, context)
File “/home/floke/.config/blender/2.79/scripts/addons/BlendLuxCore/export/init.py”, line 105, in create_session
luxcore_scene.Parse(scene_props)
RuntimeError: Syntax error in texture name: 0.4 0.4 0.4


(Floki) #63

And here just create material for box and here new error
btw linux disr Fedora 27
LuxCoreRenderEngine del
init
LuxCoreRenderEngine del
init
view_update
new session
exporter init
create_session
[SDL][157.048] Camera type: perspective
[SDL][157.049] Camera position: Point[-10.4796, -20.2917, 8.3734]
[SDL][157.049] Camera target: Point[-10.0359, -19.4459, 8.07706]
[SDL][157.049] Camera clipping plane disabled
[SDL][157.050] Material definition: 140224315804936
exporter init
ERROR: Syntax error in texture name: 0.69999998807907104 0.69999998807907104 0.69999998807907104
Traceback (most recent call last):
File “/home/floke/.config/blender/2.79/scripts/addons/BlendLuxCore/engine/viewport.py”, line 19, in view_update
engine.session = engine.exporter.create_session(scene, context)
File “/home/floke/.config/blender/2.79/scripts/addons/BlendLuxCore/export/init.py”, line 105, in create_session
luxcore_scene.Parse(scene_props)
RuntimeError: Syntax error in texture name: 0.69999998807907104 0.69999998807907104 0.69999998807907104
view_update
new session
exporter init
create_session
[SDL][157.062] Camera type: perspective
[SDL][157.063] Camera position: Point[-10.4796, -20.2917, 8.3734]
[SDL][157.063] Camera target: Point[-10.0359, -19.4459, 8.07706]
[SDL][157.063] Camera clipping plane disabled
[SDL][157.064] Material definition: 140224315804936
exporter init
ERROR: Syntax error in texture name: 0.69999998807907104 0.69999998807907104 0.69999998807907104
Traceback (most recent call last):
File “/home/floke/.config/blender/2.79/scripts/addons/BlendLuxCore/engine/viewport.py”, line 19, in view_update
engine.session = engine.exporter.create_session(scene, context)
File “/home/floke/.config/blender/2.79/scripts/addons/BlendLuxCore/export/init.py”, line 105, in create_session
luxcore_scene.Parse(scene_props)
RuntimeError: Syntax error in texture name: 0.69999998807907104 0.69999998807907104 0.69999998807907104


(oaschwab) #64

I noticed that the viewport preview renders with modifiers (subdivision surface), however the actual render does not.


(Dade) #65

@Floki, you have a quite strange problem there. I suggest you to open a thread on our forums (it is hard to follow the requests of help here, all in a single thread). It may be related to a localization problem but it is hard to say without doing some test.


(Floki) #66

Ok thanks, no problem can u give me a link where to post?
btw i saw in google that someone have the same problem with older version.


(Dade) #67

Just here: https://forums.luxcorerender.org/viewforum.php?f=4


(Floki) #68

Thanks, added post there


(tungee) #69

Dade i have 3 questions:
How do i get DOF?
I tried everything but nothing happens.

For some reason viewport GPU Opencl isnt recognized anymore. Only the final rendering uses Opencl GPU?!

The intensity for Background lightning doesnt react .


(sharlybg) #70

Select your camera ====>> under imagepipeline select DOF and play with F-stop.


But for support and fast answer please register and ask on Luxcore forum :http://forums.luxcorerender.org/index.php


(LuxCore Addon Developer) #71

It is intended. There’s a thread in our forum about it, but currently I can’t find it.

https://wiki.luxcorerender.org/BlendLuxCore_FAQ#When_I_change_the_brightness_of_my_lamp.2C_nothing_happens


(Dade) #72

It is in this thread: https://forums.luxcorerender.org/viewtopic.php?f=4&t=199&p=2571#p2571

This is directly from “Bring Arnold to GPU” presentation at last GTC (http://on-demand.gputechconf.com/gtc/2018/video/S8841/):


It shows how CPUs generate the first samples faster than GPUs while the GPUs win on the long run. Exactly why we use RTPATHCPU over RTPATHOCL.


#73

Are there any chances we will have a OS X version?
Any news about that?

Thanks,
paolo


(Dade) #74

The sources have been successful compiled on MacOS but we don’t have a MacOS developer and, unfortunately, there can not be an official release until when someone shows up.


#75

Thank you Dade, I understand.

Maybe there would be someone which occasionally compiles an unofficial build for testing the beta?

paolo


(Dade) #76

Yup, there has been, unfortunately, it was something like alpha2 and there has been 7 releases since them. I could probably dig around the forums and find the link but I don’t think is worth spending your time with such an old version.

I hope we will get on board a MacOS developer first or later: https://forums.luxcorerender.org/viewtopic.php?f=5&t=22


#77

Thanks for answer Dade!

Yes, I will wait hoping.

paolo


(tungee) #78

Thank you dade for the answers too.
I really like Luxcore already much, alltough i dont get DOF. I picket a Distance turned dof on and made Fstop to 0.3 but really no DOF.


(LuxCore Addon Developer) #79

Maybe your scene is very big? Depth of field is more noticeable in small scenes (makro photography).
By default 1 Blender unit = 1 meter.
If you still have problems I suggest you either open an issue on github or a thread in our forum so we can talk about it in more detail and you can post a scene showing the problem.


(LuxCore Addon Developer) #80

We have released the third beta release: https://forums.luxcorerender.org/viewtopic.php?f=9&p=3027#p3025
We are grateful for anyone who helps us test and uncover bugs.

If you have feature requests you are welcome to post them here: https://forums.luxcorerender.org/viewtopic.php?f=5&t=245