LuxCoreRender - How to fix fireflies/ noise

Hey all, first time BlendLuxCore user here :slight_smile:
I set up a very glass-/ caustic-heavy scene (see below),
https://pixabay.com/de/illustrations/broccoli-3d-render-blender-6560950/
with about 15k diamonds and let it render for ~3.5 hours.

This is the result:
https://pixabay.com/de/photos/broccoli-3d-render-blender-6560948/

And these are my render settings:

I reckon that 3.5 hours might simply not be enough but do you have any other tips and tricks on how to fix the massive amount of fireflies (except for longer render times)?

Note that I did set-up denoising in the compositor, but it barely changed anything if anything at all.

It might just be me, but I canโ€™t see any fireflies in the image you linked? Maybe post the version without denoising?

Do you have a GPU that supports LuxCore? If so, I suggest trying with Path Tracing (GPU) + Light Tracing (CPU) itโ€™s generally a lot faster: