LuxCoreRender v2.2

Thankyou it’s working.

I am uploading a HDRI image in the ‘world’ tab but nothing appears to be happen. Is there a need for activating some other thing in some other tab somewhere in Blender?

Also: how do we regulate the light intensity in HDRIs’ in Luxcore? I am not finding something related in the ‘world’ tab.

And furthermore: I do see all those so fast rendered caustics scenes here in the thread… I do not find the way to achieve such things in the renderer (and in such short rendering times). Why not making a very simple video tutorial showing the way of achieving such results? It would be very helpful to many people.

Luxcore is a great renderer but it needs much more easy to follow video tutorials. It is very important to have such tutorials in making much more people want to use it.

1 Like

No, but maybe you have other very bright light sources in the scene (e.g. a sun) and the tonemapper is adapting to those? The HDRI light intensity can be controlled by the “gain” property in the world tab. Try to use a higher gain (e.g. 100,000).
Maybe our FAQ could help in this case: https://wiki.luxcorerender.org/BlendLuxCore_FAQ#Why_is_my_HDRI_environment_black_and_not_showing_up.3F

About tutorials: It would be great to have more, but we need volunteers to make them.
Maybe these resources help you:

The enhanced caustic rendering techniques shown here are very new (introduced about one week ago) and not yet part of any official release (not even a beta), only available through daily builds. They need to be tested and refined more before it makes sense to create tutorials about them (for example, the UI has changed in the last days).

Thank you for your feedback, I hope I could help.

I did try to see what happens when all the other light sources in the scene are deactivated but it was in vain, the resulting render was totally black. I will try, however, to experiment again with the HDRI files. Thank you very much for the answer. Will give you feedback after making more tries.

You could also upload the .blend file with packed textures and I take a look (a stripped down version that still shows the problem is enough).

Short status update on the 2.8 port:

What works

  • Viewport render
  • Node editor/materials
  • Michael has ported most of the UI panels
  • Lights/World
  • Objects (including particles and all other kinds of instances)

Todo

  • Final render
  • View layers
  • Motion Blur
  • Hair
  • Material preview
  • … and a lot of polishing and probably tons of minor bugs that will pop up

For more details, see https://github.com/LuxCoreRender/BlendLuxCore/issues/166
Thanks to all the donors for their support! I appreciate it a lot.

23 Likes

At last I did find what was happening with the HDRI issue: In Luxcore HDRI files have to be uploaded with a Hemi light and its settings have to be regulated from the tab of this light source kind. But I still am wondering if it is so why there is a HDRI upload option in the ‘world’ tab options too.

Anyway, HDRIs are working. Now I did meet a problem with the glass material. In some scenes is not appearing at all. I will look at it again and will see.

It doesn’t matter if you use the world or a hemi light to set a HDRI.
Without a scene or some error messages I can’t guess what could be wrong in your specific case.

If you upload a .blend file, I can take a look.

Here is a very simple scene: the smaller cube on the ground has glass material on it. It is not rendering. There only appears some strange shape on the ground suggesting its base.

Luxcore_glass problem.blend (959.7 KB)

You have defined a world volume with IOR = 1.5 and your glass has the same IOR of 1.5. The result is correct (if the IORs are equal, no refraction happens).

Usually air has an IOR of 1 - when I use that as world volume, I get the result you might be looking for?

1 Like

Thanks! Now it is ok. I would never be able to find it by myself. :smiley:

I’ve been following this and anxiously waiting for 2.8. BYOB puts in a TON of work on this. I added a few bucks to the bounty as a show of thanks for all the work you do. I know you’re going to get it done anyways but your hard work doesn’t go unnoticed.
I know some people have mentioned simplifying the interface or having a couple render presets would help.
It was also a little hard for me to find the page to donate, so here’s a direct link for anyone else that’s interested.
https://www.bountysource.com/teams/luxcorerender/issues?tracker_ids=80143047

3 Likes

Thank you oaschwab!

Since a few days I’m working on a “cycles node reader” that translates Cycles nodes to LuxCore materials at export time. No actual visible node trees are modified, and you can enable/disable the usage of the Cycles nodes for each material at any time.

I have recorded some demo videos about it:

(older videos: https://youtu.be/VYNwzagnKVE and https://youtu.be/ObzwXWC4iO4)

Note that it’s very early work in progress and only very few nodes (around 5 or so) are supported right now. There’s a lot of work to be done still on this topic.

13 Likes

Awesome work @B.Y.O.B , and these caustics are impressive.
I’ve been meaning to give it a try in Blender 2.8 but I keep getting this error

Traceback (most recent call last):
  File "C:\Users\chafouin\Desktop\blender-2.80.0-git.699193713fc0-windows64\2.80\scripts\modules\addon_utils.py", line 351, in enable
    mod = __import__(module_name)
  File "C:\Users\chafouin\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\BlendLuxCore\__init__.py", line 23, in <module>
    raise Exception(msg + "\n\nImportError: %s" % error) from None
Exception:

Could not import pyluxcore.
You probably forgot to install one of the redistributable packages.
They are listed in the release announcement post.

ImportError: DLL load failed: The specified module could not be found.

I have installed the 2.79 redistributable packages. I downloaded the BlendLuxCore 2.8 refactor version from github, copied it on top of the 2.79 BlendLuxCore to make sure to have all the binaries.
Is there something else to do to make it work in 2.8?

You have to compile LuxCore with Python 3.7 instead of 3.5 (also you need to compile the https://github.com/LuxCoreRender/LuxCore/tree/blender2.80 branch).
I would give you a compiled pyluxcore, but honestly the addon is not in a state usable for end-users yet.
There will be an official alpha release once I think it makes sense.

1 Like

There seems to be a basic bug with materials, using Blender 2.79.

I set up my Lux based materials and they render just fine, I save my BLEND file and when I reopen, all the material are gone?

Lux 2.2 Alpha0 does not seem to be able to re-attach the materials to the scene, after Blender is opened again.

This is a bug in 2.79, you need 2.79b (the b is important).

Thank you, 2.79b does work correctly and even found the materials that were previously lost.

Another thing that does not seem to be working, using 2.79b, is that the denoised image is never saved to disk when I render an animation sequence.

How do I get the denoised image written to disk automatically?
I have tried with both denoiser check boxes (Render and Viewport) on and off.compare