LuxCoreRender v2.3

I found a bug, in the viewport, with light tracing caustics get brighter when zooming out from them or dimmer when getting closer, if I enable and disable light tracing or change the light tracing percentage it goes back to the correct brightness.


(For some reason the gif resolution gets very small)

It should have been fixed in v2.4:


Quick question; How to eliminate the difference between viewport and final render? Somehow they come out overexposed.

Please create a bug report at and upload a file that shows the problem.

MacOs 10.15.4 on iMac Pro Downloaded the latest release today and Luxrender still forces blender to crash while enabling it-installs fine.

Blender 2.3.13

I have problem with BCD denoiser. Intel works fine.
2.82 + 2.3

Am I doing sth wrong?

Please open an issue here:
And upload a testscene that shows the problem.

Hello and a healthy new year,

how to sharpen Caustics in Blender Luxrender, more details ?
In nature they don’t look so washed out !

Thank you in advance

Forum Caustics_1.blend (919.0 KB)

I would try this setup in the compositor and try adjusting the sharpen and often filters before they go into the denoise node… make sure you turn off denoise in the render panel so that you can manually denoise it in the compositor as shown.

in luxrender there are different pixel filters, lancoz i think is the sharpest but for the compositor setup i showed you might want Gaussian to start of with then sharpen it so you dont get black ringing artifacts so much.
I might try with that blend file but do you have a photo for reference of the look you are trying to achieve?

I updated the scene, changed a bunch of render settings and gave it a 5 min time limit and separated the caustics into its own layer, so you can do anything with them in the compositor.

The way i have set it up i boosted the caustics, denoised them gave them a filter, denoise, bloom, color, and chromatic aberration just as an example, then mixed it back in with the color add node.

Forum Caustics_1 sonofhendrix.blend (1.1 MB)

Heres a render using luxrenders camera imager settings, to give Tonemapping, F-stop, shutter, ISO,chromatic aberration, vignette, DOF, bloom, Analong Film Simulation (Kodachrome 64CD)
And i gave the scene an HRDI + the glass a normal map. 18 min render on GTX1070



Thank you very much, this is exactly what I was looking for.

Thanks again , you are my hero :wave: !

Best regards

You are welcome.
I cant upload a file with HDRI and normal map because file size way too big.

But here is a screen shot of some of the camera settings.

Also set the blender color management to RAW, and 2.2 gamma.
Use a daylight HDRI. I put thin film on the glass. i used the automatic denosie this time and no caustics boosting. These caustics come just from the HDRI no other lights rendered.

Comparison between path Engine and Bidir.

Bidir is brighter but slower to render.


@ Thesonofhendrix,

thanks again for sharing your time and knowledge with us!

Stay healthy
Love greetings


Latest Official BlendLuxCore v2.61 is out:


Not yet available for Mac.

1 Like

Will be soon asap

Awesome! Thanks!

1 Like

Will wait your great projects with LCR! ))

1 Like

Latest improved version is here: