LuxCoreRender v2.4

They are under: /home/<user_name>/.config/

Thanks! Found them.
Tested a bit. All works great.
Maybe this was mentioned, but it seems there are no caustics shown in the viewport when LT is on and added in preview. It does render correctly, though.

Quick question about scene lighting in luxCore. Is it at all possible to render with an HDRI and have a transparent background but have that transparency appear in glass? Lets say I have a glass window, and I want the light from the HDRI to pass through the window but I don’t want to see the HDRI in the windows reflections and I do want to be able to composite a different image behind the glass. I vaguely remember doing this in lux a LONG time ago but generally speaking it seems not as it is in other render engines.

Yes, just enable transparent film option and, in general, you can use alpha AOV to do any composition you want.

1 Like

Thank you @Dade. I really appreciate it. Wouldn’t the problem be in the specular AOV? Alpha will create a mask of the window but not actually disable the hdri from being visible in the window. The effect I am looking for is more of trying to remove the HDRI from the specular AOV while retaining reflections from other objects in the scene. I should say, I know this is more or less not a typical thing to try and fix. I know even in arnold this was a pain in the A and maya has AOVs for things I don’t think I have needed in the 5 years I have used it, but still. It would be particularly helpful in this particular scene I am working on. Cycles does make this easy with the transparent glass function under film, but I would rather keep it all in lux if I can and not touch cycles for this project.

For a curved surface this really wouldn’t have the most realistic results since the image would be flipped like you see on a ball but for a flat window the method should work fine since it ultimately would just displace what you see going through it.

Alternatively, does luxcore support multiple render layers, because if it does I could just render the one background image behind the glass on one layer and the HDRI on the rest.

Check the Architectural option for the glass material. That removes the refraction and uses transparency instead.

I just saw that also. Thank you. I appreciate it. It looks like the render layers works as well so I will experiment with both. I am using just a basic ball to test this on and architectural reflections just don’t quite look right because they look suddenly very dim compared to normal IOR glass, but It could be different in my scene so I am going to do a test render with that now. Scene is very dense so I will give it a shot and see what turns out of it and come back if It doesn’t feel right.

Thanks again to you both and I will update if needed.

I will update this with a revized version of the post in a minute but it is very strange, reflections are not showing up in the window at all and I am not sure if this will resolve it’self in the next pass but the background is like half transparent half not and I am not 100% sure whats causing that either but like I said I will come back when it is done because I suppose that could change in another pass. it is at only 400/1024 samples. Just, usually by now that is resolved.

(edit, it is from the reflection of the dark wall behind it, duh, thats why it’s not 100% transparent. Haha, gonna watch that reflection though because some things still aren’t yet showing up in reflections and it is a little strange but also partially why I avoid arch glass.

(edit) Yeah it basically completely ignored detailed reflections so I am going to tinker with render layers since I had some success with that.