LuxCoreRender v2.5

ou will have to ask BYOB. not very sure about that one :

2 Likes

It is logged as feature request here: https://github.com/LuxCoreRender/LuxCore/issues/258
But not actively being worked on yet.

2 Likes

LuxCore SSS wizards are invited to have a look at this LuxCore forum thread about SSS, thanks.

2 Likes

You can switch to Luxcore 2.5 alpha 0 now i think as the optix crashing bug as been solved By Dade today.
Just download the lastest build here :


And you can follow the thread here:
7 Likes

For thoses missing the lastest animation on the channel :

7 Likes

quite a lot of flickering in there to be honest…

Yes i saw it too. Theses one appear at the last minute before i start render the animation. It was already too late and didn’t have too much time left with my other activities and work stuff.
So i wann’t keep delay this project animation X time again.
Anyway aside from that I’m happy with the result considering the issue is fixable with more time.

1 Like

Get a clue a LOL 3D library next models :

8 Likes

I tried rendering a plant with subsurface scattering but I get noisy results, can anyone tell me what should I change in my Shader setup to get better results?


Is there any way to disable caustics? I tried everything I can think of…
Also setting glossy or diffuse in the light performance tab has no effect at all?

Have you tried disabling Light Tracing?
image

yes, also different percentages when on.
I know path tracers well, and just can’t seem to find any way to get rid of caustics… Doing archviz, speed is more important than caustics, and photon cache is the reason to try luxcore.

Is this really hard-coded into luxcore?

I realllly recommend some temporal noise reduction (I use Davinci Resolve Studio)! Flickers go away totally!

Just use LOL premade pl1nte shader to start in nature section :slight_smile: . And you don’t need sss for plant just glossy translucent can do the trick.

1 Like

A picture of your current issue can make it clear.
Also if you’re experiencing bad performance caustic isn’t instantly the guilty thing.
You don’t get performance in Luxcore like you do in cycles ( remove caustics or blurr reflection …).
Normally with good settings adapted to your scene you don’t need all that usual cycles tricks.
Show settings and scene configuration so we can help spot the issue.

1 Like

Have you disabled the indirect visibility in light source panel ? I’m not sure if what you are talking about are really caustics, can you post an image to show what do you mean ?

I doubt that your leaves have thickens so you can not use a volume at all. Just remove the volume from your node tree and you should be fine.

1 Like

Disabled Indirect Visibility, but it does not change anything (diffuse, glossy and specular), neither in viewport nor render.

Edit - As for why: One reason is simpler art directing - these caustics are a bit unpredictable and show up late in the render-process. And the second reason is that it just forces me to render longer as the denoiser will have to work harder.

I am aware that disabling this breaks energy conservation, but back in v-ray when a scene had heavy reflections that would eat away the light, GI-Override shaders were used to mitigate that.

Can you upload the scene?

sure: caustics.blend (664.9 KB)
thanks for looking into it!