Luxrender absolutely wont install.

I had it running just fine until i crashed my pc during a GPU render by opening up GPUZ(it can sometimes do that).
Afterwards all GPU renders would fail to compile and crash…

So i totally uninstalled it from system and tried to reinstall several times but its impossible. And i mean ive tried uninstalling lux render, uninstalling blender, deleting data from the appdata folders, running registry cleaner, re-downloading everything and trying to get blender to install the lux render addon but it always results in this error.

Traceback (most recent call last):
File “D:\Blender-2.75-windows64\2.75\scripts\modules\”, line 324, in enable
mod = import(module_name)
File “C:\Users\Tommy\AppData\Roaming\Blender Foundation\Blender\2.75\scripts\addons\”, line 115, in <module>
class LuxRenderAddonPreferences(AddonPreferences):
File “C:\Users\Tommy\AppData\Roaming\Blender Foundation\Blender\2.75\scripts\addons\”, line 123, in LuxRenderAddonPreferences
File “C:\Users\Tommy\AppData\Roaming\Blender Foundation\Blender\2.75\scripts\addons\”, line 51, in find_luxrender_path
efutil.find_config_value(‘luxrender’, ‘defaults’, ‘install_path’, ‘’)
File “C:\Users\Tommy\AppData\Roaming\Blender Foundation\Blender\2.75\scripts\addons\luxrender\extensions_framework\”, line 111, in find_config_value
cfg_files =
File “D:\Blender-2.75-windows64\2.75\python\lib\”, line 672, in read
self._read(fp, filename)
File “D:\Blender-2.75-windows64\2.75\python\lib\”, line 1058, in _read
raise MissingSectionHeaderError(fpname, lineno, line)
configparser.MissingSectionHeaderError: File contains no section headers.
file: ‘C:\Users\Tommy\AppData\Roaming\Blender Foundation\Blender\2.75\config\/luxrender.cfg’, line: 1

Tried everything it will not have it.

In terms of uninstalling, just make sure you have removed the LuixRender install (E.g. C:\Program Files\LuxRender) and the luxrender folder in the Blender addons folder (%appdata%\Blender Foundation\Blender\2.75\scripts\addons\luxrender)

Then download the suitable daily build from:

If installing LuxBlend from the build doesn’t work, then remove the LuxBlend folder, and download the latest from here:

and install that.

Hope that works

ive tried uninstalling lux render with its uninstaller,. And deleting the lux addons folder in the blender directory. And deleting the lux render folder from the app data /roaming/blender… windows folder. Tried running cc register cleaner after the uninstalls. Tried re-downloading, reinstalling and when i go to blender to direct it to the zip file for the lux blend, it will bring up that console error, and the tick box will not get ticked…

Ive tried manually extracting the contents of the luxrender zip file to those folders but it still will not allow it to have a tick in the box… Ive tried clicking “remove” under the blender add-ons tab for it. Tried everything.

Some ideas. You have a c and d drive in those error messages, you seem to have python on your d drive, which may cause confusion.

Basically, install the lux program, you should be able to open it by going to start, program files, lux It works on it’s own. If you can’t get to the point where you can open lux manually, forget trying to wire up blender for an exporter etc…

So now you have lux installed and working, now you worry about the add ons.

Yep i can get lux to open no problem. Its just the blender addon causing me problems…

I might have much bigger problems. I tried to install blender on the C:\ drive but it failed it only placed the folders and nothing else, like the exe or files that were out of folders… As if there was something wrong with my hard disk… Thats why i had to install blender on the D:\

Blender not being able to install on the c drive is a red flag. I’d go backwards uninstall blender from the d drive, make a copy of any configs/scripts/starup you have, and get blender running on c.

Blender doesn’t need to be “installed” more than once, when it writes the appdata/roaming… When I get the latest builds, I just download it, unzip it, and then copy over my scripts and configs into the new version folder (if it’s a new version), and then make a shortcut to the exe.

I finally got it to work by accident. I now have 2 versions of Blender on the C drive. One of them is a custom build by Scorpion with lots of addons. In that version i gave it a go telling it to install luxrender from file. And it worked.