Luxrender does not run

This may have been covered but I searched through the threads and could not find it.

I can not get Luxrender to open after a couple of hours of following instructions/debugging. It will run independently, but not launch from Blender.

I tried two methods and both have the same error show up (see attached image). In case the image is not clear, the error reads: “ERROR: Export aborted: [Errno 13] Permission denied: ‘C://startup.Scene.000001.lxs’”

  1. I installed one of the latest blends with everything bundled. I actually followed a recent tutorial on BlenderCookie to do so. That didn’t work. I checked Run Renderer, named the path to Luxrender Installation, etc.

  2. I tried latest LuxBlend installation per the LuxBlend 2.5 installation instructions, and using Blender 2.57. Same as above, and same error.

I do not have OpenCL (running on a Lenovo G560 laptop with basic Intel graphics), but it didn’t work with No OpenCL either.

What is this “permission denied” the console reads?

Would love any assistance.


Possibly it has to do with the UAC blocking it. Not sure without seeing the other settings though.

It does look like a permissions issue. For instance, does your current user login have administrator rights?

If not, you certainly should have permissions to write to your “My Documents” folder. Try pointing your Lux output/export to that folder, or your desktop.

The root of C: may be protected.

Where is your Blender file stored? I got the exact same error when I was testing a new Blender file (i.e. a fresh file with a cube in the middle of the screen).

I then saved the file in my projects folder (inside my “My Documents”) and rendered again - this time without the errors. You should also do what Atom has suggested and set the LuxRender output directory - I set this inside my project folder.