Luxrender help

Hi all,
Hope you folks can help me again.
I an having awful trouble installing Luxrender as a add on.I have downloaded blender 2.5 beta the latest one. And downloaded Luxrender, and also luxblend and dropped it into addons folder in “users-roaming-blenderfoundation-scripts-addons” as described in tutorials but it not there under user preferences when i open blender… I have also tried graphicall and downloaded build with Luxrender … But nothing happens when I unzip the file… I think I have tried everything… Both on laptop and desktop…
Any suggestions??
Many thanks!

You don’t have to unzip anything, if I recall, on windows.

Just pull down the SVN version from
Install LuxRender for your OS.
Then in Blender go to User Preferences click on Render and make the AddOn active.
Then you select LuxRender as your render engine, instead of Blender Internal (at the top of the screen).
Once LuxRender is set as the renderer, you have to select the Render context and scroll down till you see “Run Render”.
For some reason, this check box is off by default. So you have check that one. A browse field will appear that you have to click on and browse to the folder where you installed the LuxRender engine.


After all that you can press F12 and render.
Enjoy the scenic view while you wait, and wait, and wait, and wait, and wait, and did I say wait…

Thanks atom,
Will try again later. Just one question. If I uninstall everything and then download from graphicall will that download both blender and Luxrender in one go? And what is “svn”? Sorry for bein so useless!! Didn’t think I was but I beginning to think I am!! Ha ha

Cheers, I’ll post how it goes.

Hi again,
I tried that… I downloaded “blender 2.56a r35566 win32 with Luxrender and openMP”… I click run… And then I get a “7-zip self extracting archive” window with 2 options - “extract” and “cancel” buttons… Click extract… It extracts and disappears from screen and I cannot find files… I am really stuck… I have a fair idea what should be happening but it is simply not… Have any of you folks heard of this “7z” zip file?? Must
Be this that is causing the problem.
Thanks very much all…really appreciate the help…

Please post your support questions in the appropriate forum. Moved.

Very sorry.

Maybe try to extract the data with 7-Zip itself.

Get 7-Zip here:

Some Informations about 7-Zip for example here:

Here should be enough video-tutorials available on how to do this: