Luxrender - odd renders.

Ok guys so I was advised to use Luxrender, tbh I’ve not looked back since I got it, however, each time I render a scene I get something like the first attatchment (skull-rend1) from the 2nd attatchment (skull-eg)

I’m confused too, according to a tutorial I’m following - the metarials are set up using the Luxrender window, am I able to use my own custom metarials I’ve made especially for the mesh’s UV’s?

also, I’ve followed the tutorial steb by step and all I’m gettign as my final render is a black image with a white square (my plane mash as a light).

I’m using Blender 249.2 with Python 2.6.2 installed.

I hope somebody has some helpful answers for me :wink:


Lux does support UV mapping for meshes. You have to explicitly tell it to use UV, however, it does not auto detect that. Also UV is not the default, I believe planar is.

Also make sure to explicitly browse to your image in LuxBlend. LuxBlend will detect image maps from BLender materials, but if those maps have invalid paths, or are unreachable LuxBlend does not give you any warning (maybe in the BLender console window).

Lux does not support alpha channels at this time and I have seen it crap out on images that have alpha channels even if the alpha chanel is not used. So you may want to convert your TGA to plain old JPG just to make sure you are not experiencing an image failure by Lux.

Also, switch your tone mapping from Reinhard to Linear. Reinhard auto adjusts brightness levels which you may not want. You may want to try an environment light as your only light source until your figure out your mapping problem. Sometime lights, if they are too close, can blow out pixel color values. Just move them to an un-rendered layer for now (if you are using them).


Hey man thanks for the advice! I tried it and still no luck, all I’m getting now is a white image :confused:

no worries though, I’ve seen some nice results with the blender internal so I’ll just stick with this, all I wanted was photorealism :stuck_out_tongue: I’m sure that with anough tweeking I can manage to get my renders looking exactly how I want them :slight_smile:

just a quick question though - How do I know when the render using Lux is finished? the numbers at the bottom just keep increasing and my %tage just ranges from 0% to 121% for the same image on a different render :S I’m sorry for my núbness but this is confusing me :slight_smile:

You know what it might be. Are you using the Metropolis transport? (ie. the final best setting?) If you are not, directlighting might be failing you.

If you post your BLEND file here, I’ll take a look at it.

To stop a Lux render, there is a parameter called “haltspp”. It defaults to 0 which means it will render forever. For animated sequences you can select how long Lux will spend on each frame by setting a value for haltspp. A haltspp value of 32-40 is the equivalent of a draft version. Maybe 100 for haltspp for a better preview. Then haltspp 500-1000 for fnal renders.

Yeah, it would be the best thing to post the .blend here, or at least the image texture you’re using. This sounds like a little problem you’re just not used to…

On a side note, Luxrender’s an unbiased engine. That means that Renderings are NEVER finished. They rather converge towards a perfect simulation of the real lighting situation (it progressively solves the rendering equation, which gives physically correct results), given by the lights and objects in your scene. So, the more samples it gets, the better the image is - that means, less noise (noise stems from the fact that Lux solves the equation by using “statistic” (Monte Carlo or Las Vegas, I’d guess) methods…but enough with that, I’m just learning all that stuff, that’s why I tell you all this :stuck_out_tongue_winking_eye: ).
And another thing: how many samples are needed depends 1) on your scene and 2) on the integrator you use.
It all sounds rather confusing but it isn’t (at least not if you think about it) and Lux is a nice rendering engine to learn! Try it!