Mac 2.66 r54697 dolly pans???

Hi there not sure if anyone is experiencing this too (and I found it did it in a version of 2.56 as well), where instead of dollying with my left mouse button the viewport is panning around the scene.

I’m also using a apple magic mouse.

When I open 2.55 it all works correctly.

Here’s my file to test…

Thanks in advance.

I just tested your scene in Blender 2.63, 2.64, 2.65 and 2.66 in OS X 10.7 with a 5 button mouse (an old MS Intellimouse 3.0)
And the scene behaves perfectly normal.
Pressing the middle mouse rotates the scene as it should.
I think you would be better of with any normal mouse with a scroll wheel for blender.


Jakerlund, I’m sorry but I can not stand that someone says: have you problems with the mouse that you haven’t had before? Change your mouse! or: Do you have problems on OS X? switch to Windows!

It’s normal here, I think, that people discovering bad or strange behaviours with new revisions tell of them, asking for confirmations or solutions, and where things were working fine before, changing mouse is not the best suggestion.


Hmm ok, I’m also using MagicPref to allow my Magic Mouse to have a middle mouse button which was working fine until a few days ago when it began to open up the Dashboard on a middle click if really I was wanting it to open a new browser tab. Looks like to fix that I had to connect a mac usb mouse and make sure the middle button was made as Button 3 in the Mouse System Preferences (which it wasn’t). So I did that and that fixed the open browser tab issue but not the Blender one.

Weird how it works in Blender 2.55 but not in 2.6. BTW I’m not holding down the middle button but scrolling it back and forth.


paolo, If you use a Magic mouse you should know that issues can arise since it’s not behaving like other mice and Blender keep changing all the time.
I only provided information that his scene worked fine with another mouse.
Usually using a full featured mouse with a scroll wheel is best insurance to have things working.
I was only trying to help…


no problems to me really,

but, if you don’t use magic mouse you should know that I never had any problem with it until now, i.e. 2.66.
That Blender changes all the time is a fact that sadly has its downside.
At the moment it looks to me as some latest changes for osx have benefited laptops and trackpads at the expense of Magic mouse usability.


So are you having the same troubles too paolo?

Google glasses come with native support for blender. Just close one eye and rotate your head for panning. Also you can configure Dragon dictate for middle mouse functionality, just hum the blender theme song and displacement works on a 2-d texture created from the sound waves. Hope this helps!

slaps blenderallday

Nice, you could also capture 3d forms, turning around objects or people, or mapping real textures, looking at your meshes through what is in front of you.

I had many problems when those changes was made, such as zooming and panning both in 3d views and Image editor, zooming and panning in 2d editors (node, clips editor, etc.), panning in the panels header, zooming at cursor position, and so forth.
Now I managed to restore the most of functions but 2d views navigation.
Moreover multiple loop cuts doesn’t work anymore, and maybe other issues I don’t know, because I cannot work with such latest revisions, and I have to stick to 2.65a.


I’m having the same problem and it’s driving me nuts. Happened to me in a previous version as well. I don’t remember which one, but the following release fixed it. If there’s not an easy fix, I’m going to revert back a version. Don’t know what else to do…?

ok bugga, how did u solve the zooming in viewports?

Personally, I don’t remember how I got zooming to work again in viewports, too many tries during several revisions changes, basically, assigning ‘Mouse/Trackpad Pan’ to ‘view3d.zoom’, and avoiding any other instance of it in 3d view. (Mouse/Trackpad Zoom doesn’t work with Magic).


Thanks sourvinos!

I changed view3d.zoom to “Mouse/Trackpad Pan” and “Any” without Shift, Ctrl, Alt or Cm selected and that seemed to work, but has me worried that in future versions it’ll fix it self up and i’ll have to do this all over again. Sigh :frowning:

Thanks anyhow.

i’m pretty sure i’ve there were some changes to osx gesture behaviors to enable zooming via two fingers and such, doesn’t the magic mouse behave like a trackpad on a mouse in that case?