Mac OS X issues: speed & certain hotkeys

I have been learning blender on my powerbook, a 5 year old flaky titanium, I have now switched to my much more powerful desktop computer, a dual PPC G5 (nVIDIA GeForce FX 5200, 64MB VRAM) and I cannot use the control-right, control-left and control-up keys to shift scenes or maximise a window. There doesn’t seem to be anything wrong with the control keys for other popup menus in blender or in other applications.

The other surprise is that the menus are awfully sluggish on this faster machine, in user preferences, it can take up to 4 seconds to switch from ‘View & Controls’ to ‘Themes’. The header menus are also a bit erratic too. I have set the menus top level and sublevel to 1 (the minimum) and the problem persists.

I have downloaded another copy and tried again but nothing doing. Could somebody tell me where the preferences file lives, I can’t find it in the usual places on the Mac.

all the best:

Look in Home for a file named .B.blend and trash it. I use terminal and do a ls -al to see the files there.


Thank you Hog.

I’ve discovered that if i prevent anything else from drawing over the blender interface, the menu switching is much speedier, so I’m assuming this is an OpenGL issue.

Still no wiser on why the control-right, control-left and control-up keyboard commands don’t work.

I’ve had nary a problem graphics wise… I’m running an ATI Radeon 9600 graphics board in the G5.
I did try control-left, contol-right, control-up and control-down and that is a nice set of commands. Thanks!!
Try looking for graphics setting(s) that work? Hopefully someone else is using a card like your using and can chime in.

Thanks hogmemberisold:

You say: “Try looking for graphics setting(s) that work?”, I’m not quite sure what you mean, can you elucidate? I’m not aware of any way of adjusting the OpenGL settings or anything to do with the card, I thought these things were set in stone. I have tried reducing colours to Thousands and even 256 but all to no avail. The control key and the up/down/right/left arrows work fine with other hotkey/shortcuts but for some reason don’t work together. You’re right about the usefulness of those shortcuts, that’s why it’s such a pain to not have them on the big machine, maybe I’ll just have to work on the Powerbook and render on the G5. I’m tempted by wishes that blender wasn’t open source, then I could email a developer and maybe get the problem fixed but NO. As it is, it seems the forum is my only hope.