Mac shortcuts tutorial?

I am a newbie to blender/elysiun and am experiencing some problems [which are luckily outweighed by the attraction of actually being able to use this program properly one day! :smiley: ]

I am both a mac and ibm/pc user and the tutorials have been extremely helpful :stuck_out_tongue: , however :expressionless: , some of the shortcuts - e.g. ones involving [>] shifts - do not work on my mac [!] …

Is there a tutorial or post that has already covered this problem?

I felt it was easier to ask, but feel free to tell me to bugger off and try for myself… I know that’s what you’re meant to do really. :wink:

PS> I apologise for my exstensive use of emoticons, but this is my first post and they are so lovely!

moved topic for more related forum…and faster response… :slight_smile:

All shortcuts should work fine and be the same on PC and mac

Can we have more details about your config ?

The questioner is right. The shortcuts most definitely aren’t the same on Mac and PC.

Basically try using the Apple key (mainly instead of ctrl) sometimes. It works for me. (Bit more confused cos I’m on an iBook) But using fn/apple/alt etc. in various combinations and eventually you’ll find what works.

I’m the Os X maintener.

I know for sure that if there is any combo that doesnt work exactly like on PC, it’s not intentionnal, it’s a bug.

Now, on the powerbook G4 I use, all work fine. On others I know of, including ibooks, too.

So please be specific and says exactly which key combo does not work, on which machine and with which version of OS. Please also state which language you use, it may be needed.

BTW, blender dont even know the existence of the cmd (apple) key. cmd-q should be the only one which works.

Also try using the left shift if you use the right one.

Lukep’s right, I have an ibook and all my keys work as expected and you never have to touch the command key. I had trouble with the fn key on my laptop but it’s a case of getting the combination right. Like shift-f4, you have to do shift-fn-f4, fn-shift-f4 won’t work. It’s the same with the numpad so I just use the numpad lock now.

It’s certainly the way it works on mine.

The Apple key tends to be what ctrl is listed as being. This is a Panther iBook, and I haven’t changed any of the Blender config on that machine. I haven’t got it with me, but I’ll certainly check for you, and tell you specifically when I’ve found out.

I’m using Panther too. Are you sure you’re not just pressing command when you could do the same thing by pressing the letter on its own? Like if you do command-t, that has the same action as just pressing t.

thanks for the replies first off… :smiley:
I am using an ibook for future ref. But I am also a newbie to the mac format. Big job on hands to learn everything… [forgot to add I am using panther OS X in english]

All the single letter keys (A, B, G, S, R &c.) are working wonderfully.
by Alt i can compensate for the middle mouse, but how do I work without the RHM?

i am experiencing problems with:

- zooming in and out via shortcuts.
That is supposed to be numpad + and - right?

  • shift combos e.g. Shift + D.
    I have tried both left and right shift keys.

  • ctrl combos are not working for me. I have tried apple key, but I guess I chose the wrong combo to try because as I tried apply key + tab I flicked windows. Very interesting but nearly gave me a heart attack. I vowed not to touch apple key until further instructions…

By accident I found that Shift + Alt + mouse = panning, i think

That’s it I think. :expressionless:

It sounds like the problem is that you are using the Apple one-button mouse, which is possible to do in Blender but I wouldn’t recommend it. I would seriously recommend spending $30 on a Mac-compatible USB 3-button mouse, you’ll find Blender much easier (and faster) to use. Or a great deal is the cheaper Graphire WACOM tablet which comes with a 3-button mouse, the pen, and the pressure sensitive tablet for $100.

I’ve found a 3-button mouse (a WACOM tablet mouse in my case) to be invaluable even with other Mac software. You’d be surprised at how much software can use it :wink:

Regarding the mice issue, I use a MS trackball (with scrolly wheel!) and it works brilliantly. How anyone survives with one button I don’t quite understand.

It’s the “ctrl” shortcuts that mess up on mine too. All the single letters are fine etc. Things like Ctrl-W becomes Apple-W (sorry still haven’t got round to a comprehensive answer yet though!)

btw, I also have Expose activated, and in default settings, and my hunch is this might have something to do with it.