Macbook eGPU Blender 2.8 Eevee bug - TIP

Blender 2.8 doesn’t react on ‘Prefer External GPU’ setting in app info (Mojave) when external monitor is plugged to eGPU. The temporary solution is to fire up Blender 2.8 with closed Macbook’s upper case. When Blender is running Macbook’s case can be opened and eGPU works as a main GPU. It works for me with RX570 eGPU.

Blender fired up ‘normally’ - lagging due to partly use Intel Graphics:

Blender fired up with Macbook closed - working smooth with RX570 as main GPU:

Oh wow man that is really a life saver. For me it was worse, if I opened Blender without closing the lid and with my RX 580 eGPU attached, I wouldnt be able to even edit stuff at all. Seemed like Blender would lock me down. Very very weird behaviour.

Anyway, I tried your way and now it’s working fine. I hope the good Blender people are able to fix this issue. How can I submit a bug report for this as well?

And in your case, in terms of performance, shouldnt it run faster since it’s using 2 GPUs instead of only one? RX 570 + intel?

I found this site for bugs report:
‘Prefer External GPU’ option works great on other apps I use. I hope it will be not a big problem for developers to fix this.

For some reason Intel Graphics is a big bottleneck for Eevee/RX570 and overall Blender performance even on external monitor and better to disable it completely.

By the way there is one more positive side effect - you can select vertex/edge/face in edit mode. Really.
But if you’d like to render the project you have to close Macbook’s lid again. Otherwise you will get nice black screen because Blender stubbornly and senselessly trying to use Intel crap. Yes it is weird.