Mach Studio Pro export script another problem

hi all,

The error message I’m getting is:

Traceback <most recent call last>:
File “<string>”, line 1, in <module>
File “C:\blender 2.49b\blender-2.49b-windows.blender\scripts\StudioGPUExporter.py”, line 32, in <module>
from sgpuExportLib.sgpuExportLib import *
Import error: DLL load failed. The specified module could not be found

here’s the text of the script, from another thread:
http://www.telardigital.com/afecelis/blender/StudioGPUExporter.py

Help, please, I know nothing about python. I just want to get this script installed.

Thanks,

Tyler

You probably need to install python. Download links http://python.org/download/releases/2.7.2/

I did install Python. The instructions say it has to be Python 2.6.2. I have an Intel based computer.
Installed the 32 bit Intel version of python 2.6.2. Blender 2.49b works with it.

here are the blender exporter install instructions:


  1. THis will work only with Python2.6.2.
    I havent tested any other versions.

1)First find whether your python is 32 bit Intel version
or a 64 bit amd version. (those are the two versions that we support)
THe following script detects that.
import sys
sys.version

Please install the contents of the $(Platform)\sgpuExporterPythonBinding folder
to $(Python26Root)\Lib\site_packages\sgpuExportLib.
If you dont have such a folder, please create one.
where $(Python26Root) is the place where you have installed Python2.6.2
Eg: I have installed Python2.6.2 at c:\Python26
and $(Platform) is either ‘32bit’ or ‘64bit’.

( Done that correctly I think)

Please copy the python file ‘StudioGPUExporter.py’ to the
blender scripts directory.
Eg: C:\Users\kgeorge\AppData\Roaming\Blender Foundation\Blender.blender\scripts


I couldn’t put it in the exact location required, because if I try to create a new folder called .blender
under:
C:\Users ylerzambori\AppData\Roaming\Blender Foundation\Blender\

it does not allow me to create a new subfolder called .blend, and then
of course I cannot create a new sub-sub folder called scripts to put it

However, I did find that blender 2.49b likes to install scripts in this location:

C:\blender 2.49b/blender-2.49b-windows.blender\scripts

So I installed StudioGPUExporter.py there, but it does no good.

You’re missing sgpuExportLib which I guess should probably be bundled with the script.

Thank you; I have now installed sgpuExportLib.dll everywhere I can think, and it doesn’t work.

I copied it to:

C:\blender 2.49b\blender-2.49b-windows.blender\scripts
C:\Users ylerzambori\AppData\Roaming\Blender Foundation\Blender\blender\scripts
(in which the second blender sub-folder had not dot in front of it)

and even

C:\python26\Lib\site-packages\

and I still get that same error message.

Thanks,

Tyler